Ubuntu 6033 Published by

A file security update has been released for Ubuntu Linux 22.04 LTS.



[USN-6359-1] file vulnerability


==========================================================================
Ubuntu Security Notice USN-6359-1
September 12, 2023

file vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.04 LTS

Summary:

file could be made to crash or run programs if it opened a specially
crafted file.

Software Description:
- file: Tool to determine file types

Details:

It was discovered that file incorrectly handled certain malformed files. An
attacker could use this issue to cause a denial of service, or possibly
execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.04 LTS:
file 1:5.41-3ubuntu0.1
libmagic1 1:5.41-3ubuntu0.1

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6359-1
CVE-2022-48554

Package Information:
https://launchpad.net/ubuntu/+source/file/1:5.41-3ubuntu0.1