Ubuntu 6283 Published by

A GStreamer security update has been released for Ubuntu Linux 16.04 LTS.



[USN-6291-1] GStreamer vulnerability


==========================================================================
Ubuntu Security Notice USN-6291-1
August 16, 2023

gstreamer1.0 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 LTS (Available with Ubuntu Pro)

Summary:

GStreamer could be made to denial of service if it received a specially
crafted datetime string.

Software Description:
- gstreamer1.0: GObject introspection data for the GStreamer library

Details:

Hanno Bock discovered that GStreamer incorrecly handled certain datetime
strings. An attacker could possibly use this issue to cause a denial
of service or expose sensitive information.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 LTS (Available with Ubuntu Pro):
gstreamer1.0-tools 1.8.3-1~ubuntu0.1+esm1
libgstreamer1.0-0 1.8.3-1~ubuntu0.1+esm1

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6291-1
CVE-2017-5838