Ubuntu 6406 Published by

A MaraDNS security update has been released for Ubuntu Linux 16.04 LTS, 18.04 LTS, 20.04 LTS, 22.04 LTS, and 23.04.



[USN-6271-1] MaraDNS vulnerabilities


==========================================================================
Ubuntu Security Notice USN-6271-1
August 03, 2023

maradns vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 23.04
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS (Available with Ubuntu Pro)
- Ubuntu 16.04 LTS (Available with Ubuntu Pro)

Summary:

Several security issues were fixed in MaraDNS.

Software Description:
- maradns: A small open-source DNS server

Details:

Xiang Li discovered that MaraDNS incorrectly handled certain inputs. If a
user or an automated system were tricked into opening a specially crafted
input file, a remote attacker could possibly use this issue to obtain
sensitive information. (CVE-2022-30256)

Huascar Tejeda discovered that MaraDNS incorrectly handled certain inputs. If
a user or an automated system were tricked into opening a specially crafted
input file, a remote attacker could possibly use this issue to cause a denial
of service. (CVE-2023-31137)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 23.04:
duende 2.0.13-1.4+deb11u1build0.23.04.1
maradns 2.0.13-1.4+deb11u1build0.23.04.1
maradns-deadwood 2.0.13-1.4+deb11u1build0.23.04.1
maradns-zoneserver 2.0.13-1.4+deb11u1build0.23.04.1

Ubuntu 22.04 LTS:
duende 2.0.13-1.4+deb11u1build0.22.04.1
maradns 2.0.13-1.4+deb11u1build0.22.04.1
maradns-deadwood 2.0.13-1.4+deb11u1build0.22.04.1
maradns-zoneserver 2.0.13-1.4+deb11u1build0.22.04.1

Ubuntu 20.04 LTS:
duende 2.0.13-1.4+deb11u1build0.20.04.1
maradns 2.0.13-1.4+deb11u1build0.20.04.1
maradns-deadwood 2.0.13-1.4+deb11u1build0.20.04.1
maradns-zoneserver 2.0.13-1.4+deb11u1build0.20.04.1

Ubuntu 18.04 LTS (Available with Ubuntu Pro):
duende 2.0.13-1.2ubuntu0.1~esm1
maradns 2.0.13-1.2ubuntu0.1~esm1
maradns-deadwood 2.0.13-1.2ubuntu0.1~esm1
maradns-zoneserver 2.0.13-1.2ubuntu0.1~esm1

Ubuntu 16.04 LTS (Available with Ubuntu Pro):
duende 2.0.13-1ubuntu0.1~esm1
maradns 2.0.13-1ubuntu0.1~esm1
maradns-deadwood 2.0.13-1ubuntu0.1~esm1
maradns-zoneserver 2.0.13-1ubuntu0.1~esm1

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6271-1
CVE-2022-30256, CVE-2023-31137

Package Information:
https://launchpad.net/ubuntu/+source/maradns/2.0.13-1.4+deb11u1build0.23.04.1
https://launchpad.net/ubuntu/+source/maradns/2.0.13-1.4+deb11u1build0.22.04.1
https://launchpad.net/ubuntu/+source/maradns/2.0.13-1.4+deb11u1build0.20.04.1