Ubuntu 6289 Published by

A Nanopb security update has been released for Ubuntu Linux 20.04 LTS.



[USN-6121-1] Nanopb vulnerabilities


==========================================================================
Ubuntu Security Notice USN-6121-1
May 30, 2023

nanopb vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.04 LTS (Available with Ubuntu Pro)

Summary:

Several security issues were fixed in Nanopb.

Software Description:
- nanopb: Protocol Buffers with small code size

Details:

It was discovered that Nanopb incorrectly handled certain decode messages.
An attacker could possibly use this cause a denial of service or expose
sensitive information. (CVE-2020-26243)

It was discovered that Nanopb incorrectly handled certain decode messages.
An attacker could possibly use this issue to cause a denial of service
or execute arbitrary code. (CVE-2021-21401)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.04 LTS (Available with Ubuntu Pro):
nanopb 0.4.1-1ubuntu0.1~esm1

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6121-1
CVE-2020-26243, CVE-2021-21401