Ubuntu 6289 Published by

A Synapse security update has been released for Ubuntu Linux 18.04 ESM.



USN-6076-1: Synapse vulnerabilities


==========================================================================
Ubuntu Security Notice USN-6076-1
May 16, 2023

matrix-synapse vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 18.04 ESM

Summary:

Several security issues were fixed in Synapse.

Software Description:
- matrix-synapse: Synapse: Matrix homeserver written in Python/Twisted.

Details:

It was discovered that Synapse incorrectly handled certain inputs. If a
user or an automated system were tricked into opening a specially crafted
input file, a remote attacker could possibly use this issue to cause a
denial of service. (CVE-2019-18835, CVE-2018-12291, CVE-2018-10657)

It was discovered that Synapse incorrectly handled certain inputs. If a
user or an automated system were tricked into opening a specially crafted
input file, a remote attacker could possibly use this issue to hijack the
session. (CVE-2019-11842, CVE-2018-12423)

It was discovered that Synapse incorrectly handled certain inputs. If a
user or an automated system were tricked into opening a specially crafted
input file, a remote attacker could possibly use this issue to perform
spoofing or user impersonation. (CVE-2019-5885, CVE-2018-16515)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 18.04 ESM:
matrix-synapse 0.24.0+dfsg-1ubuntu0.1~esm1

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6076-1
CVE-2018-10657, CVE-2018-12291, CVE-2018-12423, CVE-2018-16515,
CVE-2019-11842, CVE-2019-18835, CVE-2019-5885