Ubuntu 6290 Published by

A Glance_store security update has been released Ubuntu Linux 20.04 LTS, 22.04 LTS, 22.10, and 23.04.



USN-6073-2: Glance_store vulnerability


==========================================================================
Ubuntu Security Notice USN-6073-2
May 11, 2023

python-glance-store vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 23.04
- Ubuntu 22.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS

Summary:

Glance_store could be made to expose sensitive information.

Software Description:
- python-glance-store: OpenStack Image Service store library

Details:

Jan Wasilewski and Gorka Eguileor discovered that Glance_store incorrectly
handled deleted volume attachments. An authenticated user or attacker could
possibly use this issue to gain access to sensitive information.

This update may require configuration changes to be completely effective,
please see the upstream advisory for more information:

https://security.openstack.org/ossa/OSSA-2023-003.html

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 23.04:
python3-glance-store 4.3.0-0ubuntu1.1

Ubuntu 22.10:
python3-glance-store 4.1.0-0ubuntu1.1

Ubuntu 22.04 LTS:
python3-glance-store 3.0.0-0ubuntu1.1

Ubuntu 20.04 LTS:
python3-glance-store 2.0.0-0ubuntu4.1

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6073-2
https://ubuntu.com/security/notices/USN-6073-1
CVE-2023-2088

Package Information:
https://launchpad.net/ubuntu/+source/python-glance-store/4.3.0-0ubuntu1.1
https://launchpad.net/ubuntu/+source/python-glance-store/4.1.0-0ubuntu1.1
https://launchpad.net/ubuntu/+source/python-glance-store/3.0.0-0ubuntu1.1
https://launchpad.net/ubuntu/+source/python-glance-store/2.0.0-0ubuntu4.1