Ubuntu 6290 Published by

A WebKitGTK security update has been released for Ubuntu Linux 20.04 LTS, 22.04 LTS, 22.10, and 23.04.



USN-6061-1: WebKitGTK vulnerabilities


==========================================================================
Ubuntu Security Notice USN-6061-1
May 08, 2023

webkit2gtk vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 23.04
- Ubuntu 22.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS

Summary:

Several security issues were fixed in WebKitGTK.

Software Description:
- webkit2gtk: Web content engine library for GTK+

Details:

Several security issues were discovered in the WebKitGTK Web and JavaScript
engines. If a user were tricked into viewing a malicious website, a remote
attacker could exploit a variety of issues related to web browser security,
including cross-site scripting attacks, denial of service attacks, and
arbitrary code execution.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 23.04:
libjavascriptcoregtk-4.0-18 2.40.1-0ubuntu0.23.04.1
libjavascriptcoregtk-4.1-0 2.40.1-0ubuntu0.23.04.1
libjavascriptcoregtk-6.0-1 2.40.1-0ubuntu0.23.04.1
libwebkit2gtk-4.0-37 2.40.1-0ubuntu0.23.04.1
libwebkit2gtk-4.1-0 2.40.1-0ubuntu0.23.04.1
libwebkitgtk-6.0-4 2.40.1-0ubuntu0.23.04.1

Ubuntu 22.10:
libjavascriptcoregtk-4.0-18 2.38.6-0ubuntu0.22.10.1
libjavascriptcoregtk-4.1-0 2.38.6-0ubuntu0.22.10.1
libjavascriptcoregtk-5.0-0 2.38.6-0ubuntu0.22.10.1
libwebkit2gtk-4.0-37 2.38.6-0ubuntu0.22.10.1
libwebkit2gtk-4.1-0 2.38.6-0ubuntu0.22.10.1
libwebkit2gtk-5.0-0 2.38.6-0ubuntu0.22.10.1

Ubuntu 22.04 LTS:
libjavascriptcoregtk-4.0-18 2.38.6-0ubuntu0.22.04.1
libjavascriptcoregtk-4.1-0 2.38.6-0ubuntu0.22.04.1
libwebkit2gtk-4.0-37 2.38.6-0ubuntu0.22.04.1
libwebkit2gtk-4.1-0 2.38.6-0ubuntu0.22.04.1

Ubuntu 20.04 LTS:
libjavascriptcoregtk-4.0-18 2.38.6-0ubuntu0.20.04.1
libwebkit2gtk-4.0-37 2.38.6-0ubuntu0.20.04.1

This update uses a new upstream release, which includes additional bug
fixes. After a standard system update you need to restart any applications
that use WebKitGTK, such as Epiphany, to make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6061-1
CVE-2022-0108, CVE-2022-32885, CVE-2023-25358, CVE-2023-27932,
CVE-2023-27954, CVE-2023-28205

Package Information:
https://launchpad.net/ubuntu/+source/webkit2gtk/2.40.1-0ubuntu0.23.04.1
https://launchpad.net/ubuntu/+source/webkit2gtk/2.38.6-0ubuntu0.22.10.1
https://launchpad.net/ubuntu/+source/webkit2gtk/2.38.6-0ubuntu0.22.04.1
https://launchpad.net/ubuntu/+source/webkit2gtk/2.38.6-0ubuntu0.20.04.1