Ubuntu 6289 Published by

An Erlang security update has been released for Ubuntu Linux 20.04 LTS, 22.04 LTS, and 22.10.



USN-6059-1: Erlang vulnerability


=========================================================================
Ubuntu Security Notice USN-6059-1
May 08, 2023

erlang vulnerability
=========================================================================
A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS

Summary:

Erlang could allow unintended access to network services.

Software Description:
- erlang: Concurrent, real-time, distributed functional language

Details:

It was discovered that Erlang did not properly implement TLS client
certificate validation during the TLS handshake. A remote attacker could
use this issue to bypass client authentication.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.10:
erlang 1:24.3.4.1+dfsg-1ubuntu0.1
erlang-ssl 1:24.3.4.1+dfsg-1ubuntu0.1

Ubuntu 22.04 LTS:
erlang 1:24.2.1+dfsg-1ubuntu0.1
erlang-ssl 1:24.2.1+dfsg-1ubuntu0.1

Ubuntu 20.04 LTS:
erlang 1:22.2.7+dfsg-1ubuntu0.2
erlang-ssl 1:22.2.7+dfsg-1ubuntu0.2

After a standard system update you need to reboot your computer to make
all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-6059-1
CVE-2022-37026

Package Information:
  https://launchpad.net/ubuntu/+source/erlang/1:24.3.4.1+dfsg-1ubuntu0.1
  https://launchpad.net/ubuntu/+source/erlang/1:24.2.1+dfsg-1ubuntu0.1
  https://launchpad.net/ubuntu/+source/erlang/1:22.2.7+dfsg-1ubuntu0.2