Ubuntu 6290 Published by

A Ruby regression update has been released for Ubuntu Linux 16.04 ESM, 18.04 LTS, and 20.04 LTS.



USN-6055-2: Ruby regression


=========================================================================
Ubuntu Security Notice USN-6055-2
May 05, 2023

ruby2.3, ruby2.5, ruby2.7 regression
=========================================================================
A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS
- Ubuntu 16.04 ESM

Summary:

USN-6055-1 introduced a regression.

Software Description:
- ruby2.7: Object-oriented scripting language
- ruby2.5: Object-oriented scripting language
- ruby2.3: Object-oriented scripting language

Details:

USN-6055-1 fixed a vulnerability in Ruby. Unfortunately it introduced a regression.
This update reverts the patches applied to CVE-2023-28755 in order to fix the regression
pending further investigation.

We apologize for the inconvenience.

Original advisory details:

It was discovered that Ruby incorrectly handled certain regular expressions.
An attacker could possibly use this issue to cause a denial of service.
(CVE-2023-28755)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.04 LTS:
libruby2.7 2.7.0-5ubuntu1.10
ruby2.7 2.7.0-5ubuntu1.10

Ubuntu 18.04 LTS:
libruby2.5 2.5.1-1ubuntu1.15
ruby2.5 2.5.1-1ubuntu1.15

Ubuntu 16.04 ESM:
libruby2.3 2.3.1-2~ubuntu16.04.16+esm6
ruby2.3 2.3.1-2~ubuntu16.04.16+esm6

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-6055-2
  https://ubuntu.com/security/notices/USN-6055-1
CVE-2023-28755,   https://launchpad.net/bugs/2018547

Package Information:
  https://launchpad.net/ubuntu/+source/ruby2.7/2.7.0-5ubuntu1.10
  https://launchpad.net/ubuntu/+source/ruby2.5/2.5.1-1ubuntu1.15