Ubuntu 6416 Published by

An OpenSSL-ibmca security update has been released for Ubuntu Linux 16.04 ESM, 18.04 LTS, 20.04 LTS, 22.04 LTS, and 22.10.



USN-6046-1: OpenSSL-ibmca vulnerabilities


=========================================================================
Ubuntu Security Notice USN-6046-1
April 27, 2023

openssl-ibmca vulnerabilities
=========================================================================
A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS
- Ubuntu 16.04 ESM

Summary:

OpenSSL-ibmca could be made to expose sensitive information.

Software Description:
- openssl-ibmca: libica based hardware acceleration engine for OpenSSL

Details:

It was discovered that OpenSSL-ibmca incorrectly handled certain RSA decryption.
An attacker could possibly use this issue to expose sensitive information.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.10:
openssl-ibmca 2.3.0-0ubuntu1.1

Ubuntu 22.04 LTS:
openssl-ibmca 2.2.3-0ubuntu1.1

Ubuntu 20.04 LTS:
openssl-ibmca 2.1.0-0ubuntu1.20.04.2

Ubuntu 18.04 LTS:
openssl-ibmca 1.4.1-0ubuntu1.2

Ubuntu 16.04 ESM:
openssl-ibmca 1.3.0-0ubuntu2.16.04.3

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-6046-1
  https://launchpad.net/bugs/2015454

Package Information:
  https://launchpad.net/ubuntu/+source/openssl-ibmca/2.3.0-0ubuntu1.1
  https://launchpad.net/ubuntu/+source/openssl-ibmca/2.2.3-0ubuntu1.1
  https://launchpad.net/ubuntu/+source/openssl-ibmca/2.1.0-0ubuntu1.20.04.2
  https://launchpad.net/ubuntu/+source/openssl-ibmca/1.4.1-0ubuntu1.2