Ubuntu 6283 Published by

A HAProxy security update has been released for Ubuntu Linux 22.04 LTS and 22.10.



USN-5994-1: HAProxy vulnerability


==========================================================================
Ubuntu Security Notice USN-5994-1
April 03, 2023

haproxy vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.10
- Ubuntu 22.04 LTS

Summary:

HAProxy could be made to expose sensitive information over the network.

Software Description:
- haproxy: fast and reliable load balancing reverse proxy

Details:

It was discovered that HAProxy incorrectly initialized certain connection
buffers. A remote attacker could possibly use this issue to obtain
sensitive information.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.10:
haproxy 2.4.18-1ubuntu1.3

Ubuntu 22.04 LTS:
haproxy 2.4.18-0ubuntu1.3

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-5994-1
CVE-2023-0836

Package Information:
https://launchpad.net/ubuntu/+source/haproxy/2.4.18-1ubuntu1.3
https://launchpad.net/ubuntu/+source/haproxy/2.4.18-0ubuntu1.3