Ubuntu 6283 Published by

A Protocol Buffers security update has been released for Ubuntu Linux 14.04 ESM, 18.04 LTS, 20.04 LTS, 22.04 LTS, and 22.10.



USN-5945-1: Protocol Buffers vulnerabilities


=========================================================================
Ubuntu Security Notice USN-5945-1
March 13, 2023

protobuf vulnerabilities
=========================================================================
A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS
- Ubuntu 14.04 ESM

Summary:

Several security issues were fixed in Protocol Buffers.

Software Description:
- protobuf: protocol buffers C++ library (development files)

Details:

It was discovered that Protocol Buffers did not properly validate field
com.google.protobuf.UnknownFieldSet in protobuf-java. An attacker could
possibly use this issue to perform a denial of service attack. This issue
only affected protobuf Ubuntu 22.04 LTS and Ubuntu 22.10. (CVE-2021-22569)

It was discovered that Protocol Buffers did not properly parse certain
symbols. An attacker could possibly use this issue to cause a denial of
service or other unspecified impact. (CVE-2021-22570)

It was discovered that Protocol Buffers did not properly manage memory when
parsing specifically crafted messages. An attacker could possibly use this
issue to cause applications using protobuf to crash, resulting in a denial
of service. This issue only affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS,
Ubuntu 22.04 LTS and Ubuntu 22.10. (CVE-2022-1941)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.10:
libprotobuf-java 3.12.4-1ubuntu7.22.10.1
libprotobuf-lite23 3.12.4-1ubuntu7.22.10.1
libprotobuf23 3.12.4-1ubuntu7.22.10.1
libprotoc23 3.12.4-1ubuntu7.22.10.1
protobuf-compiler 3.12.4-1ubuntu7.22.10.1
python3-protobuf 3.12.4-1ubuntu7.22.10.1

Ubuntu 22.04 LTS:
libprotobuf-java 3.12.4-1ubuntu7.22.04.1
libprotobuf-lite23 3.12.4-1ubuntu7.22.04.1
libprotobuf23 3.12.4-1ubuntu7.22.04.1
libprotoc23 3.12.4-1ubuntu7.22.04.1
protobuf-compiler 3.12.4-1ubuntu7.22.04.1
python3-protobuf 3.12.4-1ubuntu7.22.04.1

Ubuntu 20.04 LTS:
libprotobuf-lite17 3.6.1.3-2ubuntu5.2
libprotoc-dev 3.6.1.3-2ubuntu5.2
libprotoc17 3.6.1.3-2ubuntu5.2
protobuf-compiler 3.6.1.3-2ubuntu5.2
python-protobuf 3.6.1.3-2ubuntu5.2
python3-protobuf 3.6.1.3-2ubuntu5.2

Ubuntu 18.04 LTS:
libprotobuf-lite10 3.0.0-9.1ubuntu1.1
libprotobuf10 3.0.0-9.1ubuntu1.1
libprotoc10 3.0.0-9.1ubuntu1.1
protobuf-compiler 3.0.0-9.1ubuntu1.1
python-protobuf 3.0.0-9.1ubuntu1.1
python3-protobuf 3.0.0-9.1ubuntu1.1

Ubuntu 14.04 ESM:
libprotobuf-lite8 2.5.0-9ubuntu1+esm1
libprotobuf8 2.5.0-9ubuntu1+esm1
libprotoc8 2.5.0-9ubuntu1+esm1
protobuf-compiler 2.5.0-9ubuntu1+esm1

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5945-1
CVE-2021-22569, CVE-2021-22570, CVE-2022-1941

Package Information:
  https://launchpad.net/ubuntu/+source/protobuf/3.12.4-1ubuntu7.22.10.1
  https://launchpad.net/ubuntu/+source/protobuf/3.12.4-1ubuntu7.22.04.1
  https://launchpad.net/ubuntu/+source/protobuf/3.6.1.3-2ubuntu5.2
  https://launchpad.net/ubuntu/+source/protobuf/3.0.0-9.1ubuntu1.1

--5nq5yugjs2si4a7g