Ubuntu 6289 Published by

A PostgreSQL security update has been released for Ubuntu Linux 20.04 LTS, 22.04 LTS, and 22.10.



USN-5906-1: PostgreSQL vulnerability


==========================================================================
Ubuntu Security Notice USN-5906-1
March 02, 2023

postgresql-12, postgresql-14 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS

Summary:

PostgreSQL could be made to expose sensitive information over the network.

Software Description:
- postgresql-14: Object-relational SQL database
- postgresql-12: Object-relational SQL database

Details:

Jacob Champion discovered that the PostgreSQL client incorrectly handled
Kerberos authentication. If a user or automated system were tricked into
connecting to a malicious server, a remote attacker could possibly use this
issue to obtain sensitive information.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.10:
postgresql-14 14.7-0ubuntu0.22.10.1
postgresql-client-14 14.7-0ubuntu0.22.10.1

Ubuntu 22.04 LTS:
postgresql-14 14.7-0ubuntu0.22.04.1
postgresql-client-14 14.7-0ubuntu0.22.04.1

Ubuntu 20.04 LTS:
postgresql-12 12.14-0ubuntu0.20.04.1
postgresql-client-12 12.14-0ubuntu0.20.04.1

This update uses a new upstream release, which includes additional bug
fixes. After a standard system update you need to restart PostgreSQL to
make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-5906-1
CVE-2022-41862

Package Information:
https://launchpad.net/ubuntu/+source/postgresql-14/14.7-0ubuntu0.22.10.1
https://launchpad.net/ubuntu/+source/postgresql-14/14.7-0ubuntu0.22.04.1
https://launchpad.net/ubuntu/+source/postgresql-12/12.14-0ubuntu0.20.04.1