Ubuntu 6282 Published by

A lighttpd security update has been released for Ubuntu Linux 20.04 LTS, 22.04 LTS, and 22.10.



USN-5903-1: lighttpd vulnerabilities


=========================================================================
Ubuntu Security Notice USN-5903-1
February 28, 2023

lighttpd vulnerabilities
=========================================================================
A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS

Summary:

Several security issues were fixed in lighttpd.

Software Description:
- lighttpd: fast webserver with minimal memory footprint

Details:

It was discovered that lighttpd incorrectly handled certain inputs, which could
result in a stack buffer overflow. A remote attacker could possibly use this
issue to cause a denial of service (DoS). (CVE-2022-22707, CVE-2022-41556)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.10:
lighttpd 1.4.65-2ubuntu1.1

Ubuntu 22.04 LTS:
lighttpd 1.4.63-1ubuntu3.1

Ubuntu 20.04 LTS:
lighttpd 1.4.55-1ubuntu1.20.04.2

After a standard system update you need to restart lighttpd to make
all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5903-1
CVE-2022-22707, CVE-2022-41556

Package Information:
  https://launchpad.net/ubuntu/+source/lighttpd/1.4.65-2ubuntu1.1
  https://launchpad.net/ubuntu/+source/lighttpd/1.4.63-1ubuntu3.1
  https://launchpad.net/ubuntu/+source/lighttpd/1.4.55-1ubuntu1.20.04.2

--irzhjrki66gckz5v