Ubuntu 6287 Published by

An AWStats security update has been released for Ubuntu Linux 16.04 ESM, 18.04 LTS, 20.04 LTS, 22.04 LTS, and 22.10.



USN-5899-1: AWStats vulnerability


==========================================================================
Ubuntu Security Notice USN-5899-1
February 28, 2023

awstats vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS
- Ubuntu 16.04 ESM

Summary:

AWStats could allow cross-site scripting (XSS) attacks.

Software Description:
- awstats: powerful and featureful web server log analyzer

Details:

It was discovered that AWStats did not properly sanitize the content of
whois responses in the hostinfo plugin. An attacker could possibly use
this issue to conduct cross-site scripting (XSS) attacks.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.10:
awstats 7.8-2ubuntu0.22.10.1

Ubuntu 22.04 LTS:
awstats 7.8-2ubuntu0.22.04.1

Ubuntu 20.04 LTS:
awstats 7.6+dfsg-2ubuntu0.20.04.2

Ubuntu 18.04 LTS:
awstats 7.6+dfsg-2ubuntu0.18.04.2

Ubuntu 16.04 ESM:
awstats 7.4+dfsg-1ubuntu0.4+esm2

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-5899-1
CVE-2022-46391

Package Information:
https://launchpad.net/ubuntu/+source/awstats/7.8-2ubuntu0.22.10.1
https://launchpad.net/ubuntu/+source/awstats/7.8-2ubuntu0.22.04.1
https://launchpad.net/ubuntu/+source/awstats/7.6+dfsg-2ubuntu0.20.04.2
https://launchpad.net/ubuntu/+source/awstats/7.6+dfsg-2ubuntu0.18.04.2