Ubuntu 6287 Published by

A MPlayer security update has been released for Ubuntu Linux 16.04 ESM, 18.04 LTS, 20.04 LTS, 22.04 LTS, and 22.10.



USN-5895-1: MPlayer vulnerabilities


==========================================================================
Ubuntu Security Notice USN-5895-1
February 27, 2023

mplayer vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS
- Ubuntu 16.04 ESM

Summary:

Several security issues were fixed in MPlayer.

Software Description:
- mplayer: movie player for Unix-like systems

Details:

It was discovered that MPlayer could be made to divide by zero when
processing certain malformed media files. If a user were tricked into
opening a specially crafted media file, an attacker could possibly use
this issue to cause MPlayer to crash, resulting in a denial of service.
(CVE-2022-38850, CVE-2022-38860, CVE-2022-38865)

It was discovered that MPlayer could be made to read out of bounds when
processing certain malformed media files. If a user were tricked into
opening a specially crafted media file, an attacker could possibly use
this issue to cause MPlayer to crash, resulting in a denial of service.
(CVE-2022-38851)

It was discovered that MPlayer could be made to write out of bounds when
processing certain malformed media files. If a user were tricked into
opening a specially crafted media file, an attacker could possibly use
this issue to cause MPlayer to crash, resulting in a denial of service, or
possibly execute arbitrary code. (CVE-2022-38855, CVE-2022-38858,
CVE-2022-38863, CVE-2022-38864, CVE-2022-38866)

It was discovered that MPlayer did not properly managed memory when
processing certain malformed media files. If a user were tricked into
opening a specially crafted media file, an attacker could possibly use
this issue to cause MPlayer to crash, resulting in a denial of service, or
possibly execute arbitrary code. (CVE-2022-38861)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.10:
mencoder 2:1.4+ds1-3ubuntu1.1
mplayer 2:1.4+ds1-3ubuntu1.1

Ubuntu 22.04 LTS:
mencoder 2:1.4+ds1-3ubuntu0.1
mplayer 2:1.4+ds1-3ubuntu0.1

Ubuntu 20.04 LTS:
mencoder 2:1.3.0-8+deb10u1build0.20.04.1
mplayer 2:1.3.0-8+deb10u1build0.20.04.1

Ubuntu 18.04 LTS:
mencoder 2:1.3.0-7ubuntu0.2
mplayer 2:1.3.0-7ubuntu0.2

Ubuntu 16.04 ESM:
mencoder 2:1.2.1-1ubuntu1.1+esm1
mplayer 2:1.2.1-1ubuntu1.1+esm1

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-5895-1
CVE-2022-38850, CVE-2022-38851, CVE-2022-38855, CVE-2022-38858,
CVE-2022-38860, CVE-2022-38861, CVE-2022-38863, CVE-2022-38864,
CVE-2022-38865, CVE-2022-38866

Package Information:
https://launchpad.net/ubuntu/+source/mplayer/2:1.4+ds1-3ubuntu1.1
https://launchpad.net/ubuntu/+source/mplayer/2:1.4+ds1-3ubuntu0.1
https://launchpad.net/ubuntu/+source/mplayer/2:1.3.0-8+deb10u1build0.20.04.1
https://launchpad.net/ubuntu/+source/mplayer/2:1.3.0-7ubuntu0.2