Ubuntu 6283 Published by

A curl security update has been released for Ubuntu Linux 18.04 LTS, 20.04 LTS, 22.04 LTS, and 22.10.



USN-5891-1: curl vulnerabilities


==========================================================================
Ubuntu Security Notice USN-5891-1
February 27, 2023

curl vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

Several security issues were fixed in curl.

Software Description:
- curl: HTTP, HTTPS, and FTP client and client libraries

Details:

Harry Sintonen discovered that curl incorrectly handled HSTS support
when multiple URLs are requested serially. A remote attacker could possibly
use this issue to cause curl to use unencrypted connections. This issue
only affected Ubuntu 22.04 LTS, and Ubuntu 22.10. (CVE-2023-23914)

Harry Sintonen discovered that curl incorrectly handled HSTS support
when multiple URLs are requested in parallel. A remote attacker could
possibly use this issue to cause curl to use unencrypted connections. This
issue only affected Ubuntu 22.04 LTS, and Ubuntu 22.10. (CVE-2023-23915)

Patrick Monnerat discovered that curl incorrectly handled memory when
processing requests with multi-header compression. A remote attacker could
possibly use this issue to cause curl to consume resources, leading to a
denial of service. (CVE-2023-23916)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.10:
curl 7.85.0-1ubuntu0.3
libcurl3-gnutls 7.85.0-1ubuntu0.3
libcurl3-nss 7.85.0-1ubuntu0.3
libcurl4 7.85.0-1ubuntu0.3

Ubuntu 22.04 LTS:
curl 7.81.0-1ubuntu1.8
libcurl3-gnutls 7.81.0-1ubuntu1.8
libcurl3-nss 7.81.0-1ubuntu1.8
libcurl4 7.81.0-1ubuntu1.8

Ubuntu 20.04 LTS:
curl 7.68.0-1ubuntu2.16
libcurl3-gnutls 7.68.0-1ubuntu2.16
libcurl3-nss 7.68.0-1ubuntu2.16
libcurl4 7.68.0-1ubuntu2.16

Ubuntu 18.04 LTS:
curl 7.58.0-2ubuntu3.23
libcurl3-gnutls 7.58.0-2ubuntu3.23
libcurl3-nss 7.58.0-2ubuntu3.23
libcurl4 7.58.0-2ubuntu3.23

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-5891-1
CVE-2023-23914, CVE-2023-23915, CVE-2023-23916

Package Information:
https://launchpad.net/ubuntu/+source/curl/7.85.0-1ubuntu0.3
https://launchpad.net/ubuntu/+source/curl/7.81.0-1ubuntu1.8
https://launchpad.net/ubuntu/+source/curl/7.68.0-1ubuntu2.16
https://launchpad.net/ubuntu/+source/curl/7.58.0-2ubuntu3.23