Ubuntu 6287 Published by

A Git regression update has been released for Ubuntu Linux 18.04 LTS.



USN-5871-2: Git regression


=========================================================================
Ubuntu Security Notice USN-5871-2
March 02, 2023

git regression
=========================================================================
A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 18.04 LTS

Summary:

USN-5871-1 caused a regression.

Software Description:
- git: fast, scalable, distributed revision control system

Details:

USN-5871-1 fixed vulnerabilities in Git. A backport fixing
part of the vulnerability in CVE-2023-22490 was required.
This update fix this for Ubuntu 18.04 LTS.

Original advisory details:

It was discovered that Git incorrectly handled certain repositories.
An attacker could use this issue to make Git uses its local
clone optimization even when using a non-local transport.
(CVE-2023-22490)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 18.04 LTS:
git 1:2.17.1-1ubuntu0.17

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5871-2
  https://ubuntu.com/security/notices/USN-5871-1
CVE-2023-22490,   https://launchpad.net/bugs/2008277

Package Information:
  https://launchpad.net/ubuntu/+source/git/1:2.17.1-1ubuntu0.17