Ubuntu 6283 Published by

A HAProxy security update has been released for Ubuntu Linux 18.04 LTS, 20.04 LTS, 22.04 LTS, and 22.10.



USN-5869-1: HAProxy vulnerability


==========================================================================
Ubuntu Security Notice USN-5868-1
February 14, 2023

python-django vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

Django could be made to stop responding if it received specially crafted
network traffic.

Software Description:
- python-django: High-level Python web development framework

Details:

Jakob Ackermann discovered that Django incorrectly handled certain file
uploads. A remote attacker could possibly use this issue to cause Django to
consume resources, leading to a denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.10:
python3-django 3:3.2.15-1ubuntu1.2

Ubuntu 22.04 LTS:
python3-django 2:3.2.12-2ubuntu1.5

Ubuntu 20.04 LTS:
python3-django 2:2.2.12-1ubuntu0.16

Ubuntu 18.04 LTS:
python-django 1:1.11.11-1ubuntu1.20
python3-django 1:1.11.11-1ubuntu1.20

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-5868-1
CVE-2023-24580

Package Information:
https://launchpad.net/ubuntu/+source/python-django/3:3.2.15-1ubuntu1.2
https://launchpad.net/ubuntu/+source/python-django/2:3.2.12-2ubuntu1.5
https://launchpad.net/ubuntu/+source/python-django/2:2.2.12-1ubuntu0.16
https://launchpad.net/ubuntu/+source/python-django/1:1.11.11-1ubuntu1.20