Ubuntu 6376 Published by

An AdvanceCOMP security update has been released for Ubuntu Linux 16.04 ESM, 18.04 LTS, 20.04 LTS, 22.04 LTS, and 22.10.



USN-5838-1: AdvanceCOMP vulnerabilities


=========================================================================
Ubuntu Security Notice USN-5838-1
February 01, 2023

advancecomp vulnerabilities
=========================================================================
A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS
- Ubuntu 16.04 ESM

Summary:

Several security issues were fixed in AdvanceCOMP.

Software Description:
- advancecomp: collection of recompression utilities

Details:

It was discovered that AdvanceCOMP did not properly manage memory while
performing read operations on MNG file. If a user were tricked into opening
a specially crafted MNG file, a remote attacker could possibly use this
issue to cause AdvanceCOMP to crash, resulting in a denial of service.
(CVE-2022-35014, CVE-2022-35017, CVE-2022-35018, CVE-2022-35019,
CVE-2022-35020)

It was discovered that AdvanceCOMP did not properly manage memory while
performing read operations on ZIP file. If a user were tricked into opening
a specially crafted ZIP file, a remote attacker could possibly use this
issue to cause AdvanceCOMP to crash, resulting in a denial of service.
(CVE-2022-35015, CVE-2022-35016)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.10:
advancecomp 2.3-1ubuntu0.22.10.1

Ubuntu 22.04 LTS:
advancecomp 2.1-2.1ubuntu2.1

Ubuntu 20.04 LTS:
advancecomp 2.1-2.1ubuntu0.20.04.1

Ubuntu 18.04 LTS:
advancecomp 2.1-1ubuntu0.18.04.3

Ubuntu 16.04 ESM:
advancecomp 1.20-1ubuntu0.2+esm2

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5838-1
CVE-2022-35014, CVE-2022-35015, CVE-2022-35016, CVE-2022-35017,
CVE-2022-35018, CVE-2022-35019, CVE-2022-35020

Package Information:
  https://launchpad.net/ubuntu/+source/advancecomp/2.3-1ubuntu0.22.10.1
  https://launchpad.net/ubuntu/+source/advancecomp/2.1-2.1ubuntu2.1
  https://launchpad.net/ubuntu/+source/advancecomp/2.1-2.1ubuntu0.20.04.1
  https://launchpad.net/ubuntu/+source/advancecomp/2.1-1ubuntu0.18.04.3