SUSE 5058 Published by

A strongswan security update has been released for openSUSE Leap 15.4 and SUSE Linux Enterprise.



SUSE-SU-2023:4514-1: important: Security update for strongswan


# Security update for strongswan

Announcement ID: SUSE-SU-2023:4514-1
Rating: important
References:

* bsc#1216901

Cross-References:

* CVE-2023-41913

CVSS scores:

* CVE-2023-41913 ( SUSE ): 7.0 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:L

Affected Products:

* Basesystem Module 15-SP4
* openSUSE Leap 15.4
* SUSE Linux Enterprise Desktop 15 SP4
* SUSE Linux Enterprise High Performance Computing 15 SP4
* SUSE Linux Enterprise Micro 5.3
* SUSE Linux Enterprise Micro 5.4
* SUSE Linux Enterprise Real Time 15 SP4
* SUSE Linux Enterprise Server 15 SP4
* SUSE Linux Enterprise Server for SAP Applications 15 SP4
* SUSE Linux Enterprise Workstation Extension 15 SP4
* SUSE Manager Proxy 4.3
* SUSE Manager Retail Branch Server 4.3
* SUSE Manager Server 4.3
* SUSE Package Hub 15 15-SP4

An update that solves one vulnerability can now be installed.

## Description:

This update for strongswan fixes the following issues:

* CVE-2023-41913: Fixed a bug in charon-tkm related to handling DH public
values that can lead to remote code execution (bsc#1216901).

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

* openSUSE Leap 15.4
zypper in -t patch SUSE-2023-4514=1 openSUSE-SLE-15.4-2023-4514=1

* Basesystem Module 15-SP4
zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2023-4514=1

* SUSE Package Hub 15 15-SP4
zypper in -t patch SUSE-SLE-Module-Packagehub-Subpackages-15-SP4-2023-4514=1

* SUSE Linux Enterprise Workstation Extension 15 SP4
zypper in -t patch SUSE-SLE-Product-WE-15-SP4-2023-4514=1

## Package List:

* openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64 i586)
* strongswan-mysql-debuginfo-5.9.11-150400.19.17.2
* strongswan-nm-5.9.11-150400.19.17.2
* strongswan-mysql-5.9.11-150400.19.17.2
* strongswan-sqlite-5.9.11-150400.19.17.2
* strongswan-libs0-debuginfo-5.9.11-150400.19.17.2
* strongswan-debuginfo-5.9.11-150400.19.17.2
* strongswan-ipsec-5.9.11-150400.19.17.2
* strongswan-debugsource-5.9.11-150400.19.17.2
* strongswan-hmac-5.9.11-150400.19.17.2
* strongswan-sqlite-debuginfo-5.9.11-150400.19.17.2
* strongswan-ipsec-debuginfo-5.9.11-150400.19.17.2
* strongswan-libs0-5.9.11-150400.19.17.2
* strongswan-nm-debuginfo-5.9.11-150400.19.17.2
* strongswan-5.9.11-150400.19.17.2
* openSUSE Leap 15.4 (noarch)
* strongswan-doc-5.9.11-150400.19.17.2
* Basesystem Module 15-SP4 (aarch64 ppc64le s390x x86_64)
* strongswan-libs0-debuginfo-5.9.11-150400.19.17.2
* strongswan-debuginfo-5.9.11-150400.19.17.2
* strongswan-ipsec-5.9.11-150400.19.17.2
* strongswan-debugsource-5.9.11-150400.19.17.2
* strongswan-hmac-5.9.11-150400.19.17.2
* strongswan-ipsec-debuginfo-5.9.11-150400.19.17.2
* strongswan-libs0-5.9.11-150400.19.17.2
* strongswan-5.9.11-150400.19.17.2
* Basesystem Module 15-SP4 (noarch)
* strongswan-doc-5.9.11-150400.19.17.2
* SUSE Package Hub 15 15-SP4 (aarch64 ppc64le s390x x86_64)
* strongswan-debuginfo-5.9.11-150400.19.17.2
* strongswan-nm-debuginfo-5.9.11-150400.19.17.2
* strongswan-debugsource-5.9.11-150400.19.17.2
* strongswan-nm-5.9.11-150400.19.17.2
* SUSE Linux Enterprise Workstation Extension 15 SP4 (x86_64)
* strongswan-debuginfo-5.9.11-150400.19.17.2
* strongswan-nm-debuginfo-5.9.11-150400.19.17.2
* strongswan-debugsource-5.9.11-150400.19.17.2
* strongswan-nm-5.9.11-150400.19.17.2

## References:

* https://www.suse.com/security/cve/CVE-2023-41913.html
* https://bugzilla.suse.com/show_bug.cgi?id=1216901