SUSE 5054 Published by

A jetty-minimal security update has been released for openSUSE Leap 15.4/15.5 and SUSE Linux Enterprise.



SUSE-SU-2023:4210-1: important: Security update for jetty-minimal


# Security update for jetty-minimal

Announcement ID: SUSE-SU-2023:4210-1
Rating: important
References:

* bsc#1215415
* bsc#1215416
* bsc#1215417
* bsc#1216162
* bsc#1216169

Cross-References:

* CVE-2023-36478
* CVE-2023-36479
* CVE-2023-40167
* CVE-2023-41900
* CVE-2023-44487

CVSS scores:

* CVE-2023-36478 ( SUSE ): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
* CVE-2023-36478 ( NVD ): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
* CVE-2023-36479 ( SUSE ): 3.5 CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:N/I:L/A:N
* CVE-2023-36479 ( NVD ): 3.5 CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:N/I:L/A:N
* CVE-2023-40167 ( SUSE ): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
* CVE-2023-40167 ( NVD ): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
* CVE-2023-41900 ( SUSE ): 3.5 CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N
* CVE-2023-41900 ( NVD ): 3.5 CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N
* CVE-2023-44487 ( SUSE ): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
* CVE-2023-44487 ( NVD ): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:

* Development Tools Module 15-SP4
* Development Tools Module 15-SP5
* openSUSE Leap 15.4
* openSUSE Leap 15.5
* SUSE Enterprise Storage 7.1
* SUSE Linux Enterprise Desktop 15 SP4
* SUSE Linux Enterprise Desktop 15 SP5
* SUSE Linux Enterprise High Performance Computing 15 SP2
* SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2
* SUSE Linux Enterprise High Performance Computing 15 SP3
* SUSE Linux Enterprise High Performance Computing 15 SP4
* SUSE Linux Enterprise High Performance Computing 15 SP5
* SUSE Linux Enterprise High Performance Computing ESPOS 15 SP3
* SUSE Linux Enterprise High Performance Computing LTSS 15 SP3
* SUSE Linux Enterprise Real Time 15 SP4
* SUSE Linux Enterprise Real Time 15 SP5
* SUSE Linux Enterprise Server 15 SP2
* SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2
* SUSE Linux Enterprise Server 15 SP3
* SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3
* SUSE Linux Enterprise Server 15 SP4
* SUSE Linux Enterprise Server 15 SP5
* SUSE Linux Enterprise Server for SAP Applications 15 SP2
* SUSE Linux Enterprise Server for SAP Applications 15 SP3
* SUSE Linux Enterprise Server for SAP Applications 15 SP4
* SUSE Linux Enterprise Server for SAP Applications 15 SP5
* SUSE Manager Proxy 4.3
* SUSE Manager Retail Branch Server 4.3
* SUSE Manager Server 4.3

An update that solves five vulnerabilities can now be installed.

## Description:

This update for jetty-minimal fixes the following issues:

* Updated to version 9.4.53.v20231009:

* CVE-2023-44487: Fixed a potential denial of service scenario via RST frame
floods (bsc#1216169).

* CVE-2023-36478: Fixed an integer overflow in the HTTP/2 HPACK decoder
(bsc#1216162).
* CVE-2023-40167: Fixed a permissive HTTP header parsing issue that could
potentially lead to HTTP smuggling attacks (bsc#1215417).
* CVE-2023-36479: Fixed an incorrect command execution when sending requests
with certain characters in requested filenames (bsc#1215415).
* CVE-2023-41900: Fixed an issue where an invalidated session would be allowed
to perform a single request (bsc#1215416).

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

* SUSE Linux Enterprise High Performance Computing LTSS 15 SP3
zypper in -t patch SUSE-SLE-Product-HPC-15-SP3-LTSS-2023-4210=1

* SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2
zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-LTSS-2023-4210=1

* SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3
zypper in -t patch SUSE-SLE-Product-SLES-15-SP3-LTSS-2023-4210=1

* SUSE Linux Enterprise Server for SAP Applications 15 SP2
zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP2-2023-4210=1

* SUSE Linux Enterprise Server for SAP Applications 15 SP3
zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP3-2023-4210=1

* SUSE Enterprise Storage 7.1
zypper in -t patch SUSE-Storage-7.1-2023-4210=1

* openSUSE Leap 15.4
zypper in -t patch openSUSE-SLE-15.4-2023-4210=1

* openSUSE Leap 15.5
zypper in -t patch openSUSE-SLE-15.5-2023-4210=1

* Development Tools Module 15-SP4
zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP4-2023-4210=1

* Development Tools Module 15-SP5
zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP5-2023-4210=1

* SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2
zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-LTSS-2023-4210=1

* SUSE Linux Enterprise High Performance Computing ESPOS 15 SP3
zypper in -t patch SUSE-SLE-Product-HPC-15-SP3-ESPOS-2023-4210=1

## Package List:

* SUSE Linux Enterprise High Performance Computing LTSS 15 SP3 (noarch)
* jetty-server-9.4.53-150200.3.22.1
* jetty-util-9.4.53-150200.3.22.1
* jetty-http-9.4.53-150200.3.22.1
* jetty-servlet-9.4.53-150200.3.22.1
* jetty-security-9.4.53-150200.3.22.1
* jetty-io-9.4.53-150200.3.22.1
* jetty-util-ajax-9.4.53-150200.3.22.1
* SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2 (noarch)
* jetty-server-9.4.53-150200.3.22.1
* jetty-util-9.4.53-150200.3.22.1
* jetty-http-9.4.53-150200.3.22.1
* jetty-servlet-9.4.53-150200.3.22.1
* jetty-security-9.4.53-150200.3.22.1
* jetty-io-9.4.53-150200.3.22.1
* jetty-util-ajax-9.4.53-150200.3.22.1
* SUSE Linux Enterprise Server 15 SP3 LTSS 15-SP3 (noarch)
* jetty-server-9.4.53-150200.3.22.1
* jetty-util-9.4.53-150200.3.22.1
* jetty-http-9.4.53-150200.3.22.1
* jetty-servlet-9.4.53-150200.3.22.1
* jetty-security-9.4.53-150200.3.22.1
* jetty-io-9.4.53-150200.3.22.1
* jetty-util-ajax-9.4.53-150200.3.22.1
* SUSE Linux Enterprise Server for SAP Applications 15 SP2 (noarch)
* jetty-server-9.4.53-150200.3.22.1
* jetty-util-9.4.53-150200.3.22.1
* jetty-http-9.4.53-150200.3.22.1
* jetty-servlet-9.4.53-150200.3.22.1
* jetty-security-9.4.53-150200.3.22.1
* jetty-io-9.4.53-150200.3.22.1
* jetty-util-ajax-9.4.53-150200.3.22.1
* SUSE Linux Enterprise Server for SAP Applications 15 SP3 (noarch)
* jetty-server-9.4.53-150200.3.22.1
* jetty-util-9.4.53-150200.3.22.1
* jetty-http-9.4.53-150200.3.22.1
* jetty-servlet-9.4.53-150200.3.22.1
* jetty-security-9.4.53-150200.3.22.1
* jetty-io-9.4.53-150200.3.22.1
* jetty-util-ajax-9.4.53-150200.3.22.1
* SUSE Enterprise Storage 7.1 (noarch)
* jetty-server-9.4.53-150200.3.22.1
* jetty-util-9.4.53-150200.3.22.1
* jetty-http-9.4.53-150200.3.22.1
* jetty-servlet-9.4.53-150200.3.22.1
* jetty-security-9.4.53-150200.3.22.1
* jetty-io-9.4.53-150200.3.22.1
* jetty-util-ajax-9.4.53-150200.3.22.1
* openSUSE Leap 15.4 (noarch)
* jetty-cdi-9.4.53-150200.3.22.1
* jetty-servlets-9.4.53-150200.3.22.1
* jetty-util-9.4.53-150200.3.22.1
* jetty-rewrite-9.4.53-150200.3.22.1
* jetty-ant-9.4.53-150200.3.22.1
* jetty-openid-9.4.53-150200.3.22.1
* jetty-start-9.4.53-150200.3.22.1
* jetty-io-9.4.53-150200.3.22.1
* jetty-fcgi-9.4.53-150200.3.22.1
* jetty-util-ajax-9.4.53-150200.3.22.1
* jetty-webapp-9.4.53-150200.3.22.1
* jetty-proxy-9.4.53-150200.3.22.1
* jetty-continuation-9.4.53-150200.3.22.1
* jetty-server-9.4.53-150200.3.22.1
* jetty-quickstart-9.4.53-150200.3.22.1
* jetty-annotations-9.4.53-150200.3.22.1
* jetty-servlet-9.4.53-150200.3.22.1
* jetty-jndi-9.4.53-150200.3.22.1
* jetty-minimal-javadoc-9.4.53-150200.3.22.1
* jetty-plus-9.4.53-150200.3.22.1
* jetty-http-spi-9.4.53-150200.3.22.1
* jetty-xml-9.4.53-150200.3.22.1
* jetty-jmx-9.4.53-150200.3.22.1
* jetty-http-9.4.53-150200.3.22.1
* jetty-jsp-9.4.53-150200.3.22.1
* jetty-deploy-9.4.53-150200.3.22.1
* jetty-client-9.4.53-150200.3.22.1
* jetty-security-9.4.53-150200.3.22.1
* jetty-jaas-9.4.53-150200.3.22.1
* openSUSE Leap 15.5 (noarch)
* jetty-cdi-9.4.53-150200.3.22.1
* jetty-servlets-9.4.53-150200.3.22.1
* jetty-util-9.4.53-150200.3.22.1
* jetty-rewrite-9.4.53-150200.3.22.1
* jetty-ant-9.4.53-150200.3.22.1
* jetty-openid-9.4.53-150200.3.22.1
* jetty-start-9.4.53-150200.3.22.1
* jetty-io-9.4.53-150200.3.22.1
* jetty-fcgi-9.4.53-150200.3.22.1
* jetty-util-ajax-9.4.53-150200.3.22.1
* jetty-webapp-9.4.53-150200.3.22.1
* jetty-proxy-9.4.53-150200.3.22.1
* jetty-continuation-9.4.53-150200.3.22.1
* jetty-server-9.4.53-150200.3.22.1
* jetty-quickstart-9.4.53-150200.3.22.1
* jetty-annotations-9.4.53-150200.3.22.1
* jetty-servlet-9.4.53-150200.3.22.1
* jetty-jndi-9.4.53-150200.3.22.1
* jetty-minimal-javadoc-9.4.53-150200.3.22.1
* jetty-plus-9.4.53-150200.3.22.1
* jetty-http-spi-9.4.53-150200.3.22.1
* jetty-xml-9.4.53-150200.3.22.1
* jetty-jmx-9.4.53-150200.3.22.1
* jetty-http-9.4.53-150200.3.22.1
* jetty-jsp-9.4.53-150200.3.22.1
* jetty-deploy-9.4.53-150200.3.22.1
* jetty-client-9.4.53-150200.3.22.1
* jetty-security-9.4.53-150200.3.22.1
* jetty-jaas-9.4.53-150200.3.22.1
* Development Tools Module 15-SP4 (noarch)
* jetty-server-9.4.53-150200.3.22.1
* jetty-util-9.4.53-150200.3.22.1
* jetty-http-9.4.53-150200.3.22.1
* jetty-servlet-9.4.53-150200.3.22.1
* jetty-security-9.4.53-150200.3.22.1
* jetty-io-9.4.53-150200.3.22.1
* jetty-util-ajax-9.4.53-150200.3.22.1
* Development Tools Module 15-SP5 (noarch)
* jetty-server-9.4.53-150200.3.22.1
* jetty-util-9.4.53-150200.3.22.1
* jetty-http-9.4.53-150200.3.22.1
* jetty-servlet-9.4.53-150200.3.22.1
* jetty-security-9.4.53-150200.3.22.1
* jetty-io-9.4.53-150200.3.22.1
* jetty-util-ajax-9.4.53-150200.3.22.1
* SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2 (noarch)
* jetty-server-9.4.53-150200.3.22.1
* jetty-util-9.4.53-150200.3.22.1
* jetty-http-9.4.53-150200.3.22.1
* jetty-servlet-9.4.53-150200.3.22.1
* jetty-security-9.4.53-150200.3.22.1
* jetty-io-9.4.53-150200.3.22.1
* jetty-util-ajax-9.4.53-150200.3.22.1
* SUSE Linux Enterprise High Performance Computing ESPOS 15 SP3 (noarch)
* jetty-server-9.4.53-150200.3.22.1
* jetty-util-9.4.53-150200.3.22.1
* jetty-http-9.4.53-150200.3.22.1
* jetty-servlet-9.4.53-150200.3.22.1
* jetty-security-9.4.53-150200.3.22.1
* jetty-io-9.4.53-150200.3.22.1
* jetty-util-ajax-9.4.53-150200.3.22.1

## References:

* https://www.suse.com/security/cve/CVE-2023-36478.html
* https://www.suse.com/security/cve/CVE-2023-36479.html
* https://www.suse.com/security/cve/CVE-2023-40167.html
* https://www.suse.com/security/cve/CVE-2023-41900.html
* https://www.suse.com/security/cve/CVE-2023-44487.html
* https://bugzilla.suse.com/show_bug.cgi?id=1215415
* https://bugzilla.suse.com/show_bug.cgi?id=1215416
* https://bugzilla.suse.com/show_bug.cgi?id=1215417
* https://bugzilla.suse.com/show_bug.cgi?id=1216162
* https://bugzilla.suse.com/show_bug.cgi?id=1216169