SUSE 5000 Published by

A pipewire security update has been released for openSUSE Leap 15.4.



SUSE-SU-2023:3185-1: moderate: Security update for pipewire


# Security update for pipewire

Announcement ID: SUSE-SU-2023:3185-1
Rating: moderate
References:

* #1213682

Affected Products:

* openSUSE Leap 15.4

An update that has one fix can now be installed.

## Description:

This update for pipewire fixes the following security issues:

* Fixed issue where an app which only has permission to access one stream can
also access other streams (bsc#1213682).

Bugfixes: \- Fixed division by 0 and other issues with invalid values
(glfo#pipewire/pipewire#2953) \- Fixed an overflow resulting in choppy sound in
some cases (glfo#pipewire/pipewire#2680)

## Patch Instructions:

To install this SUSE Moderate update use the SUSE recommended installation
methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

* openSUSE Leap 15.4
zypper in -t patch openSUSE-SLE-15.4-2023-3185=1

## Package List:

* openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64)
* pipewire-modules-0.3.24-150300.4.6.1
* pipewire-modules-debuginfo-0.3.24-150300.4.6.1
* openSUSE Leap 15.4 (x86_64)
* pipewire-modules-32bit-debuginfo-0.3.24-150300.4.6.1
* pipewire-modules-32bit-0.3.24-150300.4.6.1

## References:

* https://bugzilla.suse.com/show_bug.cgi?id=1213682