SUSE 5000 Published by

An openssl-3 security update has been released for openSUSE Leap 15.4 and SUSE Linux Enterprise 15 SP4.



SUSE-SU-2023:3013-1: moderate: Security update for openssl-3


# Security update for openssl-3

Announcement ID: SUSE-SU-2023:3013-1
Rating: moderate
References:

* #1213383
* #1213487

Cross-References:

* CVE-2023-2975
* CVE-2023-3446

CVSS scores:

* CVE-2023-2975 ( SUSE ): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
* CVE-2023-2975 ( NVD ): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
* CVE-2023-3446 ( SUSE ): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Affected Products:

* Basesystem Module 15-SP4
* openSUSE Leap 15.4
* SUSE Linux Enterprise Desktop 15 SP4
* SUSE Linux Enterprise High Performance Computing 15 SP4
* SUSE Linux Enterprise Real Time 15 SP4
* SUSE Linux Enterprise Server 15 SP4
* SUSE Linux Enterprise Server for SAP Applications 15 SP4
* SUSE Manager Proxy 4.3
* SUSE Manager Retail Branch Server 4.3
* SUSE Manager Server 4.3

An update that solves two vulnerabilities can now be installed.

## Description:

This update for openssl-3 fixes the following issues:

* CVE-2023-2975: Fixed AES-SIV implementation ignores empty associated data
entries (bsc#1213383).
* CVE-2023-3446: Fixed DH_check() excessive time with over sized modulus
(bsc#1213487).

## Patch Instructions:

To install this SUSE Moderate update use the SUSE recommended installation
methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

* openSUSE Leap 15.4
zypper in -t patch SUSE-2023-3013=1 openSUSE-SLE-15.4-2023-3013=1

* Basesystem Module 15-SP4
zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2023-3013=1

## Package List:

* openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64 i586)
* libopenssl3-debuginfo-3.0.8-150400.4.31.2
* libopenssl-3-devel-3.0.8-150400.4.31.2
* openssl-3-debugsource-3.0.8-150400.4.31.2
* openssl-3-3.0.8-150400.4.31.2
* openssl-3-debuginfo-3.0.8-150400.4.31.2
* libopenssl3-3.0.8-150400.4.31.2
* openSUSE Leap 15.4 (x86_64)
* libopenssl-3-devel-32bit-3.0.8-150400.4.31.2
* libopenssl3-32bit-3.0.8-150400.4.31.2
* libopenssl3-32bit-debuginfo-3.0.8-150400.4.31.2
* openSUSE Leap 15.4 (noarch)
* openssl-3-doc-3.0.8-150400.4.31.2
* openSUSE Leap 15.4 (aarch64_ilp32)
* libopenssl3-64bit-debuginfo-3.0.8-150400.4.31.2
* libopenssl-3-devel-64bit-3.0.8-150400.4.31.2
* libopenssl3-64bit-3.0.8-150400.4.31.2
* Basesystem Module 15-SP4 (aarch64 ppc64le s390x x86_64)
* libopenssl3-debuginfo-3.0.8-150400.4.31.2
* libopenssl-3-devel-3.0.8-150400.4.31.2
* openssl-3-debugsource-3.0.8-150400.4.31.2
* openssl-3-3.0.8-150400.4.31.2
* openssl-3-debuginfo-3.0.8-150400.4.31.2
* libopenssl3-3.0.8-150400.4.31.2

## References:

* https://www.suse.com/security/cve/CVE-2023-2975.html
* https://www.suse.com/security/cve/CVE-2023-3446.html
* https://bugzilla.suse.com/show_bug.cgi?id=1213383
* https://bugzilla.suse.com/show_bug.cgi?id=1213487