SUSE 5000 Published by

A mysql-connector-java security update has been released for openSUSE Leap 15.4 and 15.5.



SUSE-SU-2023:2979-1: moderate: Security update for mysql-connector-java


# Security update for mysql-connector-java

Announcement ID: SUSE-SU-2023:2979-1
Rating: moderate
References:

* #1211247

Cross-References:

* CVE-2023-21971

CVSS scores:

* CVE-2023-21971 ( SUSE ): 5.3 CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:H
* CVE-2023-21971 ( NVD ): 5.3 CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:H

Affected Products:

* openSUSE Leap 15.4
* openSUSE Leap 15.5

An update that solves one vulnerability can now be installed.

## Description:

This update for mysql-connector-java fixes the following issues:

* CVE-2023-21971: Fixed a denial-of-service vulnerability in the
java.sql.DriverManager.getConnection() method when used with untrusted
inputs (bsc#1211247).

## Patch Instructions:

To install this SUSE Moderate update use the SUSE recommended installation
methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

* openSUSE Leap 15.4
zypper in -t patch openSUSE-SLE-15.4-2023-2979=1

* openSUSE Leap 15.5
zypper in -t patch openSUSE-SLE-15.5-2023-2979=1

## Package List:

* openSUSE Leap 15.4 (noarch)
* mysql-connector-java-8.0.33-150200.3.18.1
* openSUSE Leap 15.5 (noarch)
* mysql-connector-java-8.0.33-150200.3.18.1

## References:

* https://www.suse.com/security/cve/CVE-2023-21971.html
* https://bugzilla.suse.com/show_bug.cgi?id=1211247