SUSE 5001 Published by

A python-scipy security update has been released for openSUSE Leap 15.4/15.5.



SUSE-SU-2023:2970-1: moderate: Security update for python-scipy


# Security update for python-scipy

Announcement ID: SUSE-SU-2023:2970-1
Rating: moderate
References:

* #1213062
* #1213137

Cross-References:

* CVE-2023-25399
* CVE-2023-29824

CVSS scores:

* CVE-2023-25399 ( SUSE ): 3.3 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
* CVE-2023-25399 ( NVD ): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
* CVE-2023-29824 ( SUSE ): 6.7 CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
* CVE-2023-29824 ( NVD ): 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:

* openSUSE Leap 15.4
* openSUSE Leap 15.5

An update that solves two vulnerabilities can now be installed.

## Description:

This update for python-scipy fixes the following issues:

* CVE-2023-25399: Fixed minor refcounting issue in Py_FindObjects
(bsc#1213062).
* CVE-2023-29824: Fixed use-after-free in Py_FindObjects (bsc#1213137).

## Patch Instructions:

To install this SUSE Moderate update use the SUSE recommended installation
methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

* openSUSE Leap 15.4
zypper in -t patch openSUSE-SLE-15.4-2023-2970=1

* openSUSE Leap 15.5
zypper in -t patch openSUSE-SLE-15.5-2023-2970=1

## Package List:

* openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64)
* python-scipy-debuginfo-1.2.0-150100.4.6.1
* openSUSE Leap 15.4 (aarch64 ppc64le x86_64)
* python-scipy_1_2_0-gnu-hpc-debuginfo-1.2.0-150100.4.6.1
* python3-scipy_1_2_0-gnu-hpc-debuginfo-1.2.0-150100.4.6.1
* python3-scipy_1_2_0-gnu-hpc-1.2.0-150100.4.6.1
* python-scipy_1_2_0-gnu-hpc-debugsource-1.2.0-150100.4.6.1
* openSUSE Leap 15.5 (aarch64 ppc64le x86_64)
* python-scipy_1_2_0-gnu-hpc-debuginfo-1.2.0-150100.4.6.1
* python3-scipy_1_2_0-gnu-hpc-debuginfo-1.2.0-150100.4.6.1
* python3-scipy_1_2_0-gnu-hpc-1.2.0-150100.4.6.1
* python-scipy_1_2_0-gnu-hpc-debugsource-1.2.0-150100.4.6.1

## References:

* https://www.suse.com/security/cve/CVE-2023-25399.html
* https://www.suse.com/security/cve/CVE-2023-29824.html
* https://bugzilla.suse.com/show_bug.cgi?id=1213062
* https://bugzilla.suse.com/show_bug.cgi?id=1213137