SUSE 5000 Published by

An openssl-1_1 security update has been released for openSUSE Leap 15.4/Micro 5.3/5.4 and SUSE Linux Enterprise.



SUSE-SU-2023:2962-1: moderate: Security update for openssl-1_1


# Security update for openssl-1_1

Announcement ID: SUSE-SU-2023:2962-1
Rating: moderate
References:

* #1213487

Cross-References:

* CVE-2023-3446

CVSS scores:

* CVE-2023-3446 ( SUSE ): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Affected Products:

* Basesystem Module 15-SP4
* openSUSE Leap 15.4
* openSUSE Leap Micro 5.3
* openSUSE Leap Micro 5.4
* SUSE Linux Enterprise Desktop 15 SP4
* SUSE Linux Enterprise High Performance Computing 15 SP4
* SUSE Linux Enterprise Micro 5.3
* SUSE Linux Enterprise Micro 5.4
* SUSE Linux Enterprise Micro for Rancher 5.3
* SUSE Linux Enterprise Micro for Rancher 5.4
* SUSE Linux Enterprise Real Time 15 SP4
* SUSE Linux Enterprise Server 15 SP4
* SUSE Linux Enterprise Server for SAP Applications 15 SP4
* SUSE Manager Proxy 4.3
* SUSE Manager Retail Branch Server 4.3
* SUSE Manager Server 4.3

An update that solves one vulnerability can now be installed.

## Description:

This update for openssl-1_1 fixes the following issues:

* CVE-2023-3446: Fixed DH_check() excessive time with over sized modulus
(bsc#1213487).

## Patch Instructions:

To install this SUSE Moderate update use the SUSE recommended installation
methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

* openSUSE Leap 15.4
zypper in -t patch openSUSE-SLE-15.4-2023-2962=1 SUSE-2023-2962=1

* openSUSE Leap Micro 5.3
zypper in -t patch openSUSE-Leap-Micro-5.3-2023-2962=1

* openSUSE Leap Micro 5.4
zypper in -t patch openSUSE-Leap-Micro-5.4-2023-2962=1

* SUSE Linux Enterprise Micro for Rancher 5.3
zypper in -t patch SUSE-SLE-Micro-5.3-2023-2962=1

* SUSE Linux Enterprise Micro 5.3
zypper in -t patch SUSE-SLE-Micro-5.3-2023-2962=1

* SUSE Linux Enterprise Micro for Rancher 5.4
zypper in -t patch SUSE-SLE-Micro-5.4-2023-2962=1

* SUSE Linux Enterprise Micro 5.4
zypper in -t patch SUSE-SLE-Micro-5.4-2023-2962=1

* Basesystem Module 15-SP4
zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2023-2962=1

## Package List:

* openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64 i586)
* libopenssl1_1-debuginfo-1.1.1l-150400.7.48.1
* openssl-1_1-1.1.1l-150400.7.48.1
* libopenssl1_1-1.1.1l-150400.7.48.1
* openssl-1_1-debugsource-1.1.1l-150400.7.48.1
* libopenssl1_1-hmac-1.1.1l-150400.7.48.1
* libopenssl-1_1-devel-1.1.1l-150400.7.48.1
* openssl-1_1-debuginfo-1.1.1l-150400.7.48.1
* openSUSE Leap 15.4 (x86_64)
* libopenssl1_1-32bit-1.1.1l-150400.7.48.1
* libopenssl1_1-hmac-32bit-1.1.1l-150400.7.48.1
* libopenssl-1_1-devel-32bit-1.1.1l-150400.7.48.1
* libopenssl1_1-32bit-debuginfo-1.1.1l-150400.7.48.1
* openSUSE Leap 15.4 (noarch)
* openssl-1_1-doc-1.1.1l-150400.7.48.1
* openSUSE Leap 15.4 (aarch64_ilp32)
* libopenssl-1_1-devel-64bit-1.1.1l-150400.7.48.1
* libopenssl1_1-64bit-debuginfo-1.1.1l-150400.7.48.1
* libopenssl1_1-64bit-1.1.1l-150400.7.48.1
* libopenssl1_1-hmac-64bit-1.1.1l-150400.7.48.1
* openSUSE Leap Micro 5.3 (aarch64 x86_64)
* libopenssl1_1-debuginfo-1.1.1l-150400.7.48.1
* openssl-1_1-1.1.1l-150400.7.48.1
* libopenssl1_1-1.1.1l-150400.7.48.1
* openssl-1_1-debugsource-1.1.1l-150400.7.48.1
* libopenssl1_1-hmac-1.1.1l-150400.7.48.1
* libopenssl-1_1-devel-1.1.1l-150400.7.48.1
* openssl-1_1-debuginfo-1.1.1l-150400.7.48.1
* openSUSE Leap Micro 5.4 (aarch64 s390x x86_64)
* libopenssl1_1-debuginfo-1.1.1l-150400.7.48.1
* openssl-1_1-1.1.1l-150400.7.48.1
* libopenssl1_1-1.1.1l-150400.7.48.1
* openssl-1_1-debugsource-1.1.1l-150400.7.48.1
* libopenssl1_1-hmac-1.1.1l-150400.7.48.1
* libopenssl-1_1-devel-1.1.1l-150400.7.48.1
* openssl-1_1-debuginfo-1.1.1l-150400.7.48.1
* SUSE Linux Enterprise Micro for Rancher 5.3 (aarch64 s390x x86_64)
* libopenssl1_1-debuginfo-1.1.1l-150400.7.48.1
* openssl-1_1-1.1.1l-150400.7.48.1
* libopenssl1_1-1.1.1l-150400.7.48.1
* openssl-1_1-debugsource-1.1.1l-150400.7.48.1
* libopenssl1_1-hmac-1.1.1l-150400.7.48.1
* libopenssl-1_1-devel-1.1.1l-150400.7.48.1
* openssl-1_1-debuginfo-1.1.1l-150400.7.48.1
* SUSE Linux Enterprise Micro 5.3 (aarch64 s390x x86_64)
* libopenssl1_1-debuginfo-1.1.1l-150400.7.48.1
* openssl-1_1-1.1.1l-150400.7.48.1
* libopenssl1_1-1.1.1l-150400.7.48.1
* openssl-1_1-debugsource-1.1.1l-150400.7.48.1
* libopenssl1_1-hmac-1.1.1l-150400.7.48.1
* libopenssl-1_1-devel-1.1.1l-150400.7.48.1
* openssl-1_1-debuginfo-1.1.1l-150400.7.48.1
* SUSE Linux Enterprise Micro for Rancher 5.4 (aarch64 s390x x86_64)
* libopenssl1_1-debuginfo-1.1.1l-150400.7.48.1
* openssl-1_1-1.1.1l-150400.7.48.1
* libopenssl1_1-1.1.1l-150400.7.48.1
* openssl-1_1-debugsource-1.1.1l-150400.7.48.1
* libopenssl1_1-hmac-1.1.1l-150400.7.48.1
* libopenssl-1_1-devel-1.1.1l-150400.7.48.1
* openssl-1_1-debuginfo-1.1.1l-150400.7.48.1
* SUSE Linux Enterprise Micro 5.4 (aarch64 s390x x86_64)
* libopenssl1_1-debuginfo-1.1.1l-150400.7.48.1
* openssl-1_1-1.1.1l-150400.7.48.1
* libopenssl1_1-1.1.1l-150400.7.48.1
* openssl-1_1-debugsource-1.1.1l-150400.7.48.1
* libopenssl1_1-hmac-1.1.1l-150400.7.48.1
* libopenssl-1_1-devel-1.1.1l-150400.7.48.1
* openssl-1_1-debuginfo-1.1.1l-150400.7.48.1
* Basesystem Module 15-SP4 (aarch64 ppc64le s390x x86_64)
* libopenssl1_1-debuginfo-1.1.1l-150400.7.48.1
* openssl-1_1-1.1.1l-150400.7.48.1
* libopenssl1_1-1.1.1l-150400.7.48.1
* openssl-1_1-debugsource-1.1.1l-150400.7.48.1
* libopenssl1_1-hmac-1.1.1l-150400.7.48.1
* libopenssl-1_1-devel-1.1.1l-150400.7.48.1
* openssl-1_1-debuginfo-1.1.1l-150400.7.48.1
* Basesystem Module 15-SP4 (x86_64)
* libopenssl1_1-32bit-1.1.1l-150400.7.48.1
* libopenssl1_1-hmac-32bit-1.1.1l-150400.7.48.1
* libopenssl-1_1-devel-32bit-1.1.1l-150400.7.48.1
* libopenssl1_1-32bit-debuginfo-1.1.1l-150400.7.48.1

## References:

* https://www.suse.com/security/cve/CVE-2023-3446.html
* https://bugzilla.suse.com/show_bug.cgi?id=1213487