SUSE 5053 Published by

A libcap security update has been released for openSUSE Leap 15.4 and SUSE Linux Enterprise.



SUSE-SU-2023:2956-1: moderate: Security update for libcap


# Security update for libcap

Announcement ID: SUSE-SU-2023:2956-1
Rating: moderate
References:

* #1211419

Cross-References:

* CVE-2023-2603

CVSS scores:

* CVE-2023-2603 ( SUSE ): 4.4 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
* CVE-2023-2603 ( NVD ): 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Affected Products:

* openSUSE Leap 15.4
* SUSE Linux Enterprise Micro 5.1
* SUSE Linux Enterprise Micro 5.2
* SUSE Linux Enterprise Micro for Rancher 5.2
* SUSE Linux Enterprise Real Time 15 SP3
* SUSE Manager Proxy 4.2
* SUSE Manager Retail Branch Server 4.2
* SUSE Manager Server 4.2

An update that solves one vulnerability can now be installed.

## Description:

This update for libcap fixes the following issues:

* CVE-2023-2603: Fixed an integer overflow or wraparound in
libcap/cap_alloc.c:_libcap_strdup() (bsc#1211419).

## Patch Instructions:

To install this SUSE Moderate update use the SUSE recommended installation
methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

* SUSE Manager Proxy 4.2
zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Proxy-4.2-2023-2956=1

* SUSE Manager Retail Branch Server 4.2
zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Retail-Branch-
Server-4.2-2023-2956=1

* SUSE Manager Server 4.2
zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Server-4.2-2023-2956=1

* SUSE Linux Enterprise Micro 5.1
zypper in -t patch SUSE-SUSE-MicroOS-5.1-2023-2956=1

* SUSE Linux Enterprise Micro 5.2
zypper in -t patch SUSE-SUSE-MicroOS-5.2-2023-2956=1

* SUSE Linux Enterprise Micro for Rancher 5.2
zypper in -t patch SUSE-SUSE-MicroOS-5.2-2023-2956=1

* openSUSE Leap 15.4
zypper in -t patch openSUSE-SLE-15.4-2023-2956=1

* SUSE Linux Enterprise Real Time 15 SP3
zypper in -t patch SUSE-SLE-Product-RT-15-SP3-2023-2956=1

## Package List:

* SUSE Manager Proxy 4.2 (x86_64)
* libcap2-2.26-150000.4.9.1
* libcap2-32bit-2.26-150000.4.9.1
* libcap2-32bit-debuginfo-2.26-150000.4.9.1
* libcap-progs-2.26-150000.4.9.1
* libcap-progs-debuginfo-2.26-150000.4.9.1
* libcap2-debuginfo-2.26-150000.4.9.1
* libcap-debugsource-2.26-150000.4.9.1
* libcap-devel-2.26-150000.4.9.1
* SUSE Manager Retail Branch Server 4.2 (x86_64)
* libcap2-2.26-150000.4.9.1
* libcap2-32bit-2.26-150000.4.9.1
* libcap2-32bit-debuginfo-2.26-150000.4.9.1
* libcap-progs-2.26-150000.4.9.1
* libcap-progs-debuginfo-2.26-150000.4.9.1
* libcap2-debuginfo-2.26-150000.4.9.1
* libcap-debugsource-2.26-150000.4.9.1
* libcap-devel-2.26-150000.4.9.1
* SUSE Manager Server 4.2 (ppc64le s390x x86_64)
* libcap2-2.26-150000.4.9.1
* libcap-progs-2.26-150000.4.9.1
* libcap-progs-debuginfo-2.26-150000.4.9.1
* libcap2-debuginfo-2.26-150000.4.9.1
* libcap-debugsource-2.26-150000.4.9.1
* libcap-devel-2.26-150000.4.9.1
* SUSE Manager Server 4.2 (x86_64)
* libcap2-32bit-2.26-150000.4.9.1
* libcap2-32bit-debuginfo-2.26-150000.4.9.1
* SUSE Linux Enterprise Micro 5.1 (aarch64 s390x x86_64)
* libcap2-2.26-150000.4.9.1
* libcap2-debuginfo-2.26-150000.4.9.1
* libcap-debugsource-2.26-150000.4.9.1
* SUSE Linux Enterprise Micro 5.2 (aarch64 s390x x86_64)
* libcap2-2.26-150000.4.9.1
* libcap2-debuginfo-2.26-150000.4.9.1
* libcap-debugsource-2.26-150000.4.9.1
* SUSE Linux Enterprise Micro for Rancher 5.2 (aarch64 s390x x86_64)
* libcap2-2.26-150000.4.9.1
* libcap2-debuginfo-2.26-150000.4.9.1
* libcap-debugsource-2.26-150000.4.9.1
* openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64)
* pam_cap-2.26-150000.4.9.1
* pam_cap-debuginfo-2.26-150000.4.9.1
* openSUSE Leap 15.4 (x86_64)
* pam_cap-32bit-2.26-150000.4.9.1
* pam_cap-32bit-debuginfo-2.26-150000.4.9.1
* SUSE Linux Enterprise Real Time 15 SP3 (x86_64)
* libcap2-2.26-150000.4.9.1
* libcap2-32bit-2.26-150000.4.9.1
* libcap2-32bit-debuginfo-2.26-150000.4.9.1
* libcap-progs-2.26-150000.4.9.1
* libcap-progs-debuginfo-2.26-150000.4.9.1
* libcap2-debuginfo-2.26-150000.4.9.1
* libcap-debugsource-2.26-150000.4.9.1
* libcap-devel-2.26-150000.4.9.1

## References:

* https://www.suse.com/security/cve/CVE-2023-2603.html
* https://bugzilla.suse.com/show_bug.cgi?id=1211419