SUSE 5000 Published by

An openvswitch security update has been released for openSUSE Leap 15.5.



SUSE-SU-2023:2250-2: important: Security update for openvswitch


# Security update for openvswitch

Announcement ID: SUSE-SU-2023:2250-2
Rating: important
References:

* #1206580
* #1206581

Cross-References:

* CVE-2022-4337
* CVE-2022-4338

CVSS scores:

* CVE-2022-4337 ( SUSE ): 7.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
* CVE-2022-4337 ( NVD ): 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
* CVE-2022-4338 ( SUSE ): 7.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
* CVE-2022-4338 ( NVD ): 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:

* openSUSE Leap 15.5

An update that solves two vulnerabilities can now be installed.

## Description:

This update for openvswitch fixes the following issues:

* CVE-2022-4338: Fixed Integer Underflow in Organization Specific TLV
(bsc#1206580).
* CVE-2022-4337: Fixed Out-of-Bounds Read in Organization Specific TLV
(bsc#1206581).

## Patch Instructions:

To install this SUSE Important update use the SUSE recommended installation
methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

* openSUSE Leap 15.5
zypper in -t patch openSUSE-SLE-15.5-2023-2250=1

## Package List:

* openSUSE Leap 15.5 (aarch64 ppc64le s390x x86_64)
* openvswitch-debuginfo-2.14.2-150400.24.6.1
* openvswitch-test-2.14.2-150400.24.6.1
* libopenvswitch-2_14-0-debuginfo-2.14.2-150400.24.6.1
* ovn-central-debuginfo-20.06.2-150400.24.6.1
* libovn-20_06-0-debuginfo-20.06.2-150400.24.6.1
* ovn-vtep-debuginfo-20.06.2-150400.24.6.1
* ovn-debuginfo-20.06.2-150400.24.6.1
* ovn-central-20.06.2-150400.24.6.1
* openvswitch-devel-2.14.2-150400.24.6.1
* ovn-20.06.2-150400.24.6.1
* python3-ovs-2.14.2-150400.24.6.1
* ovn-devel-20.06.2-150400.24.6.1
* openvswitch-2.14.2-150400.24.6.1
* openvswitch-vtep-2.14.2-150400.24.6.1
* libovn-20_06-0-20.06.2-150400.24.6.1
* ovn-docker-20.06.2-150400.24.6.1
* openvswitch-pki-2.14.2-150400.24.6.1
* ovn-host-20.06.2-150400.24.6.1
* libopenvswitch-2_14-0-2.14.2-150400.24.6.1
* ovn-vtep-20.06.2-150400.24.6.1
* openvswitch-test-debuginfo-2.14.2-150400.24.6.1
* ovn-host-debuginfo-20.06.2-150400.24.6.1
* openvswitch-debugsource-2.14.2-150400.24.6.1
* openvswitch-ipsec-2.14.2-150400.24.6.1
* openvswitch-vtep-debuginfo-2.14.2-150400.24.6.1
* openSUSE Leap 15.5 (noarch)
* openvswitch-doc-2.14.2-150400.24.6.1
* ovn-doc-20.06.2-150400.24.6.1

## References:

* https://www.suse.com/security/cve/CVE-2022-4337.html
* https://www.suse.com/security/cve/CVE-2022-4338.html
* https://bugzilla.suse.com/show_bug.cgi?id=1206580
* https://bugzilla.suse.com/show_bug.cgi?id=1206581