SUSE 5002 Published by

A prometheus-ha_cluster_exporter security update has been released for SUSE Linux Enterprise and openSUSE Leap 15.4.



SUSE-SU-2023:0465-1: important: Security update for prometheus-ha_cluster_exporter


SUSE Security Update: Security update for prometheus-ha_cluster_exporter ______________________________________________________________________________

Announcement ID: SUSE-SU-2023:0465-1
Rating: important
References: #1208046 #1208047
Cross-References: CVE-2022-46146
CVSS scores:
CVE-2022-46146 (NVD) : 8.8 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVE-2022-46146 (SUSE): 8.8 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Affected Products:
SUSE Linux Enterprise Module for SAP Applications 15-SP2SUSE Linux Enterprise Module for SAP Applications 15-SP3SUSE Linux Enterprise Module for SAP Applications 15-SP4SUSE Linux Enterprise Server for SAP Applications 15-SP2SUSE Linux Enterprise Server for SAP Applications 15-SP3SUSE Linux Enterprise Server for SAP Applications 15-SP4openSUSE Leap 15.4
______________________________________________________________________________

An update that solves one vulnerability and has one errata is now available.

Description:

This update for prometheus-ha_cluster_exporter fixes the following issues:

Updated to version 1.3.1:

- CVE-2022-46146: Fixed authentication bypass via cache poisoning in prometheus/exporter-toolkit (bsc#1208046, bsc#1208047).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:
- openSUSE Leap 15.4:

zypper in -t patch openSUSE-SLE-15.4-2023-465=1

- SUSE Linux Enterprise Module for SAP Applications 15-SP4:
zypper in -t patch SUSE-SLE-Module-SAP-Applications-15-SP4-2023-465=1
- SUSE Linux Enterprise Module for SAP Applications 15-SP3:
zypper in -t patch SUSE-SLE-Module-SAP-Applications-15-SP3-2023-465=1
- SUSE Linux Enterprise Module for SAP Applications 15-SP2:
zypper in -t patch SUSE-SLE-Module-SAP-Applications-15-SP2-2023-465=1

Package List:

- openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

prometheus-ha_cluster_exporter-1.3.1+git.1676027782.ad3c0e9-150200.3.21.1

- SUSE Linux Enterprise Module for SAP Applications 15-SP4 (aarch64 ppc64le s390x x86_64):

prometheus-ha_cluster_exporter-1.3.1+git.1676027782.ad3c0e9-150200.3.21.1

- SUSE Linux Enterprise Module for SAP Applications 15-SP3 (aarch64 ppc64le s390x x86_64):

prometheus-ha_cluster_exporter-1.3.1+git.1676027782.ad3c0e9-150200.3.21.1

- SUSE Linux Enterprise Module for SAP Applications 15-SP2 (aarch64 ppc64le s390x x86_64):

prometheus-ha_cluster_exporter-1.3.1+git.1676027782.ad3c0e9-150200.3.21.1

References:

  https://www.suse.com/security/cve/CVE-2022-46146.html
  https://bugzilla.suse.com/1208046
  https://bugzilla.suse.com/1208047