SUSE 5000 Published by

An ImageMagick security update has been released for SUSE Linux Enterprise and openSUSE Leap 15.4.



SUSE-SU-2023:0428-1: important: Security update for ImageMagick


SUSE Security Update: Security update for ImageMagick
______________________________________________________________________________

Announcement ID: SUSE-SU-2023:0428-1
Rating: important
References: #1207982 #1207983
Cross-References: CVE-2022-44267 CVE-2022-44268
CVSS scores:
CVE-2022-44267 (NVD) : 6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVE-2022-44267 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE-2022-44268 (NVD) : 6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
CVE-2022-44268 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products:
SUSE Linux Enterprise Desktop 15-SP4
SUSE Linux Enterprise High Performance Computing 15-SP4 SUSE Linux Enterprise Module for Desktop Applications 15-SP4
SUSE Linux Enterprise Module for Development Tools 15-SP4
SUSE Linux Enterprise Server 15-SP4
SUSE Linux Enterprise Server for SAP Applications 15-SP4SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
openSUSE Leap 15.4
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.
Description:

This update for ImageMagick fixes the following issues:

- CVE-2022-44267: Fixed a denial of service when parsing a PNG image (bsc#1207982).
- CVE-2022-44268: Fixed arbitrary file disclosure when parsing a PNG image
(bsc#1207983).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:
- openSUSE Leap 15.4:

zypper in -t patch openSUSE-SLE-15.4-2023-428=1

- SUSE Linux Enterprise Module for Development Tools 15-SP4:
zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP4-2023-428=1
- SUSE Linux Enterprise Module for Desktop Applications 15-SP4:
zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP4-2023-428=1


Package List:

- openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

ImageMagick-7.1.0.9-150400.6.12.1
ImageMagick-config-7-SUSE-7.1.0.9-150400.6.12.1
ImageMagick-config-7-upstream-7.1.0.9-150400.6.12.1
ImageMagick-debuginfo-7.1.0.9-150400.6.12.1
ImageMagick-debugsource-7.1.0.9-150400.6.12.1
ImageMagick-devel-7.1.0.9-150400.6.12.1
ImageMagick-extra-7.1.0.9-150400.6.12.1
ImageMagick-extra-debuginfo-7.1.0.9-150400.6.12.1
libMagick++-7_Q16HDRI5-7.1.0.9-150400.6.12.1
libMagick++-7_Q16HDRI5-debuginfo-7.1.0.9-150400.6.12.1 libMagick++-devel-7.1.0.9-150400.6.12.1
libMagickCore-7_Q16HDRI10-7.1.0.9-150400.6.12.1
libMagickCore-7_Q16HDRI10-debuginfo-7.1.0.9-150400.6.12.1 libMagickWand-7_Q16HDRI10-7.1.0.9-150400.6.12.1
libMagickWand-7_Q16HDRI10-debuginfo-7.1.0.9-150400.6.12.1 perl-PerlMagick-7.1.0.9-150400.6.12.1
perl-PerlMagick-debuginfo-7.1.0.9-150400.6.12.1

- openSUSE Leap 15.4 (x86_64):

ImageMagick-devel-32bit-7.1.0.9-150400.6.12.1
libMagick++-7_Q16HDRI5-32bit-7.1.0.9-150400.6.12.1
libMagick++-7_Q16HDRI5-32bit-debuginfo-7.1.0.9-150400.6.12.1 libMagick++-devel-32bit-7.1.0.9-150400.6.12.1
libMagickCore-7_Q16HDRI10-32bit-7.1.0.9-150400.6.12.1 libMagickCore-7_Q16HDRI10-32bit-debuginfo-7.1.0.9-150400.6.12.1 libMagickWand-7_Q16HDRI10-32bit-7.1.0.9-150400.6.12.1 libMagickWand-7_Q16HDRI10-32bit-debuginfo-7.1.0.9-150400.6.12.1
- openSUSE Leap 15.4 (noarch):

ImageMagick-doc-7.1.0.9-150400.6.12.1

- SUSE Linux Enterprise Module for Development Tools 15-SP4 (aarch64 ppc64le s390x x86_64):

ImageMagick-debuginfo-7.1.0.9-150400.6.12.1
ImageMagick-debugsource-7.1.0.9-150400.6.12.1
perl-PerlMagick-7.1.0.9-150400.6.12.1
perl-PerlMagick-debuginfo-7.1.0.9-150400.6.12.1

- SUSE Linux Enterprise Module for Desktop Applications 15-SP4 (aarch64 ppc64le s390x x86_64):

ImageMagick-7.1.0.9-150400.6.12.1
ImageMagick-config-7-SUSE-7.1.0.9-150400.6.12.1
ImageMagick-config-7-upstream-7.1.0.9-150400.6.12.1
ImageMagick-debuginfo-7.1.0.9-150400.6.12.1
ImageMagick-debugsource-7.1.0.9-150400.6.12.1
ImageMagick-devel-7.1.0.9-150400.6.12.1
libMagick++-7_Q16HDRI5-7.1.0.9-150400.6.12.1
libMagick++-7_Q16HDRI5-debuginfo-7.1.0.9-150400.6.12.1 libMagick++-devel-7.1.0.9-150400.6.12.1
libMagickCore-7_Q16HDRI10-7.1.0.9-150400.6.12.1
libMagickCore-7_Q16HDRI10-debuginfo-7.1.0.9-150400.6.12.1 libMagickWand-7_Q16HDRI10-7.1.0.9-150400.6.12.1
libMagickWand-7_Q16HDRI10-debuginfo-7.1.0.9-150400.6.12.1

References:

  https://www.suse.com/security/cve/CVE-2022-44267.html
  https://www.suse.com/security/cve/CVE-2022-44268.html
  https://bugzilla.suse.com/1207982
  https://bugzilla.suse.com/1207983