SUSE 5058 Published by

A krb5 security update has been released for SUSE Linux Enterprise and openSUSE Leap 15.4/Micro 5.3.



SUSE-SU-2022:4153-1: important: Security update for krb5


SUSE Security Update: Security update for krb5
______________________________________________________________________________

Announcement ID: SUSE-SU-2022:4153-1
Rating: important
References: #1205126
Cross-References: CVE-2022-42898
CVSS scores:
CVE-2022-42898 (SUSE): 6.4 CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:H/A:L

Affected Products:
SUSE Linux Enterprise Desktop 15-SP4
SUSE Linux Enterprise High Performance Computing 15-SP4 SUSE Linux Enterprise Micro 5.3
SUSE Linux Enterprise Module for Basesystem 15-SP4 SUSE Linux Enterprise Module for Server Applications 15-SP4
SUSE Linux Enterprise Server 15-SP4
SUSE Linux Enterprise Server for SAP Applications 15-SP4SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
openSUSE Leap 15.4
openSUSE Leap Micro 5.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.
Description:

This update for krb5 fixes the following issues:

- CVE-2022-42898: Fixed integer overflow in PAC parsing (bsc#1205126).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:
- openSUSE Leap Micro 5.3:

zypper in -t patch openSUSE-Leap-Micro-5.3-2022-4153=1
- openSUSE Leap 15.4:

zypper in -t patch openSUSE-SLE-15.4-2022-4153=1

- SUSE Linux Enterprise Module for Server Applications 15-SP4:
zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP4-2022-4153=1

- SUSE Linux Enterprise Module for Basesystem 15-SP4:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2022-4153=1
- SUSE Linux Enterprise Micro 5.3:

zypper in -t patch SUSE-SLE-Micro-5.3-2022-4153=1


Package List:

- openSUSE Leap Micro 5.3 (aarch64 x86_64):

krb5-1.19.2-150400.3.3.1
krb5-debuginfo-1.19.2-150400.3.3.1
krb5-debugsource-1.19.2-150400.3.3.1

- openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

krb5-1.19.2-150400.3.3.1
krb5-client-1.19.2-150400.3.3.1
krb5-client-debuginfo-1.19.2-150400.3.3.1
krb5-debuginfo-1.19.2-150400.3.3.1
krb5-debugsource-1.19.2-150400.3.3.1
krb5-devel-1.19.2-150400.3.3.1
krb5-plugin-kdb-ldap-1.19.2-150400.3.3.1
krb5-plugin-kdb-ldap-debuginfo-1.19.2-150400.3.3.1
krb5-plugin-preauth-otp-1.19.2-150400.3.3.1
krb5-plugin-preauth-otp-debuginfo-1.19.2-150400.3.3.1 krb5-plugin-preauth-pkinit-1.19.2-150400.3.3.1
krb5-plugin-preauth-pkinit-debuginfo-1.19.2-150400.3.3.1 krb5-plugin-preauth-spake-1.19.2-150400.3.3.1
krb5-plugin-preauth-spake-debuginfo-1.19.2-150400.3.3.1 krb5-server-1.19.2-150400.3.3.1
krb5-server-debuginfo-1.19.2-150400.3.3.1

- openSUSE Leap 15.4 (x86_64):

krb5-32bit-1.19.2-150400.3.3.1
krb5-32bit-debuginfo-1.19.2-150400.3.3.1
krb5-devel-32bit-1.19.2-150400.3.3.1

- SUSE Linux Enterprise Module for Server Applications 15-SP4 (aarch64 ppc64le s390x x86_64):

krb5-debuginfo-1.19.2-150400.3.3.1
krb5-debugsource-1.19.2-150400.3.3.1
krb5-plugin-kdb-ldap-1.19.2-150400.3.3.1
krb5-plugin-kdb-ldap-debuginfo-1.19.2-150400.3.3.1
krb5-server-1.19.2-150400.3.3.1
krb5-server-debuginfo-1.19.2-150400.3.3.1

- SUSE Linux Enterprise Module for Basesystem 15-SP4 (aarch64 ppc64le s390x x86_64):

krb5-1.19.2-150400.3.3.1
krb5-client-1.19.2-150400.3.3.1
krb5-client-debuginfo-1.19.2-150400.3.3.1
krb5-debuginfo-1.19.2-150400.3.3.1
krb5-debugsource-1.19.2-150400.3.3.1
krb5-devel-1.19.2-150400.3.3.1
krb5-plugin-preauth-otp-1.19.2-150400.3.3.1
krb5-plugin-preauth-otp-debuginfo-1.19.2-150400.3.3.1 krb5-plugin-preauth-pkinit-1.19.2-150400.3.3.1
krb5-plugin-preauth-pkinit-debuginfo-1.19.2-150400.3.3.1
- SUSE Linux Enterprise Module for Basesystem 15-SP4 (x86_64):
krb5-32bit-1.19.2-150400.3.3.1
krb5-32bit-debuginfo-1.19.2-150400.3.3.1

- SUSE Linux Enterprise Micro 5.3 (aarch64 s390x x86_64):
krb5-1.19.2-150400.3.3.1
krb5-debuginfo-1.19.2-150400.3.3.1
krb5-debugsource-1.19.2-150400.3.3.1

References:

  https://www.suse.com/security/cve/CVE-2022-42898.html
  https://bugzilla.suse.com/1205126