SUSE 5055 Published by

A go1.19 security update has been released for SUSE Linux Enterprise and openSUSE Leap 15.3/15.4.



SUSE-SU-2022:4054-1: Security update for go1.19


SUSE Security Update: Security update for go1.19
______________________________________________________________________________

Announcement ID: SUSE-SU-2022:4054-1
Rating: low
References: #1200441 #1204941
Cross-References: CVE-2022-41716
CVSS scores:
CVE-2022-41716 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVE-2022-41716 (SUSE): 0 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:N

Affected Products:
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise Desktop 15-SP3
SUSE Linux Enterprise Desktop 15-SP4
SUSE Linux Enterprise High Performance Computing 15-SP3 SUSE Linux Enterprise High Performance Computing 15-SP4 SUSE Linux Enterprise Module for Development Tools 15-SP3
SUSE Linux Enterprise Module for Development Tools 15-SP4
SUSE Linux Enterprise Server 15-SP3
SUSE Linux Enterprise Server 15-SP4
SUSE Linux Enterprise Server for SAP Applications 15-SP3SUSE Linux Enterprise Server for SAP Applications 15-SP4SUSE Manager Proxy 4.2
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.2
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.2
SUSE Manager Server 4.3
openSUSE Leap 15.3
openSUSE Leap 15.4
______________________________________________________________________________

An update that solves one vulnerability and has one errata is now available.

Description:

This update for go1.19 fixes the following issues:

Update to go 1.19.3 (released 2022-11-01) (bsc#1200441):
Security fixes:
- CVE-2022-41716: Fixed unsanitized NUL in environment variables in syscalls, os/exec (go#56327) (bsc#1204941).

Bugfixes:
- runtime: lock count" fatal error when cgo is enabled (go#56308). - cmd/compile: libFuzzer instrumentation fakePC overflow on 386 arch (go#56168).
- internal/fuzz: array literal initialization causes ICE "unhandled stmt
ASOP" while fuzzing (go#56106).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:
- openSUSE Leap 15.4:

zypper in -t patch openSUSE-SLE-15.4-2022-4054=1

- openSUSE Leap 15.3:

zypper in -t patch openSUSE-SLE-15.3-2022-4054=1

- SUSE Linux Enterprise Module for Development Tools 15-SP4:
zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP4-2022-4054=1

- SUSE Linux Enterprise Module for Development Tools 15-SP3:
zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP3-2022-4054=1


Package List:

- openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

go1.19-1.19.3-150000.1.15.1
go1.19-doc-1.19.3-150000.1.15.1

- openSUSE Leap 15.4 (aarch64 x86_64):

go1.19-race-1.19.3-150000.1.15.1

- openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

go1.19-1.19.3-150000.1.15.1
go1.19-doc-1.19.3-150000.1.15.1

- openSUSE Leap 15.3 (aarch64 x86_64):

go1.19-race-1.19.3-150000.1.15.1

- SUSE Linux Enterprise Module for Development Tools 15-SP4 (aarch64 ppc64le s390x x86_64):

go1.19-1.19.3-150000.1.15.1
go1.19-doc-1.19.3-150000.1.15.1

- SUSE Linux Enterprise Module for Development Tools 15-SP4 (aarch64 x86_64):

go1.19-race-1.19.3-150000.1.15.1

- SUSE Linux Enterprise Module for Development Tools 15-SP3 (aarch64 ppc64le s390x x86_64):

go1.19-1.19.3-150000.1.15.1
go1.19-doc-1.19.3-150000.1.15.1

- SUSE Linux Enterprise Module for Development Tools 15-SP3 (aarch64 x86_64):

go1.19-race-1.19.3-150000.1.15.1

References:

  https://www.suse.com/security/cve/CVE-2022-41716.html
  https://bugzilla.suse.com/1200441
  https://bugzilla.suse.com/1204941