SUSE 5055 Published by

A webkit2gtk3 security update has been released for SUSE Linux Enterprise and openSUSE 15.4.



SUSE-SU-2022:2071-1: important: Security update for webkit2gtk3


SUSE Security Update: Security update for webkit2gtk3
______________________________________________________________________________

Announcement ID: SUSE-SU-2022:2071-1
Rating: important
References: #1199287 #1200106
Cross-References: CVE-2022-26700 CVE-2022-26709 CVE-2022-26716 CVE-2022-26717 CVE-2022-26719 CVE-2022-30293
CVSS scores:
CVE-2022-26700 (SUSE): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE-2022-26709 (SUSE): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE-2022-26716 (SUSE): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE-2022-26717 (SUSE): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE-2022-26719 (SUSE): 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE-2022-30293 (NVD) : 7.5 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE-2022-30293 (SUSE): 6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Affected Products:
SUSE Linux Enterprise Desktop 15-SP4
SUSE Linux Enterprise High Performance Computing 15-SP4 SUSE Linux Enterprise Module for Basesystem 15-SP4 SUSE Linux Enterprise Module for Desktop Applications 15-SP4
SUSE Linux Enterprise Module for Development Tools 15-SP4
SUSE Linux Enterprise Server 15-SP4
SUSE Linux Enterprise Server for SAP Applications 15-SP4openSUSE Leap 15.4
______________________________________________________________________________

An update that fixes 6 vulnerabilities is now available.
Description:

This update for webkit2gtk3 fixes the following issues:

Update to version 2.36.3 (bsc#1200106)

- CVE-2022-30293: Fixed heap-based buffer overflow in
WebCore::TextureMapperLayer::setContentsLayer (bsc#1199287). - CVE-2022-26700: Fixed memory corruption issue that may lead to code execution when processing maliciously crafted web content (bsc#1200106).
- CVE-2022-26709: Fixed use after free issue that may lead to code execution when processing maliciously crafted web content (bsc#1200106).
- CVE-2022-26716: Fixed use after free issue that may lead to code execution when processing maliciously crafted web content (bsc#1200106).
- CVE-2022-26717: Fixed memory corruption issue that may lead to code execution when processing maliciously crafted web content (bsc#1200106).
- CVE-2022-26719: Fixed memory corruption issue that may lead to code execution when processing maliciously crafted web content (bsc#1200106).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:
- openSUSE Leap 15.4:

zypper in -t patch openSUSE-SLE-15.4-2022-2071=1

- SUSE Linux Enterprise Module for Development Tools 15-SP4:
zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP4-2022-2071=1

- SUSE Linux Enterprise Module for Desktop Applications 15-SP4:
zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP4-2022-2071=1

- SUSE Linux Enterprise Module for Basesystem 15-SP4:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2022-2071=1

Package List:

- openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

libjavascriptcoregtk-4_0-18-2.36.3-150400.4.3.1
libjavascriptcoregtk-4_0-18-debuginfo-2.36.3-150400.4.3.1 libjavascriptcoregtk-4_1-0-2.36.3-150400.4.3.1
libjavascriptcoregtk-4_1-0-debuginfo-2.36.3-150400.4.3.1 libjavascriptcoregtk-5_0-0-2.36.3-150400.4.3.1
libjavascriptcoregtk-5_0-0-debuginfo-2.36.3-150400.4.3.1 libwebkit2gtk-4_0-37-2.36.3-150400.4.3.1
libwebkit2gtk-4_0-37-debuginfo-2.36.3-150400.4.3.1
libwebkit2gtk-4_1-0-2.36.3-150400.4.3.1
libwebkit2gtk-4_1-0-debuginfo-2.36.3-150400.4.3.1
libwebkit2gtk-5_0-0-2.36.3-150400.4.3.1
libwebkit2gtk-5_0-0-debuginfo-2.36.3-150400.4.3.1
typelib-1_0-JavaScriptCore-4_0-2.36.3-150400.4.3.1
typelib-1_0-JavaScriptCore-4_1-2.36.3-150400.4.3.1
typelib-1_0-JavaScriptCore-5_0-2.36.3-150400.4.3.1
typelib-1_0-WebKit2-4_0-2.36.3-150400.4.3.1
typelib-1_0-WebKit2-4_1-2.36.3-150400.4.3.1
typelib-1_0-WebKit2-5_0-2.36.3-150400.4.3.1
typelib-1_0-WebKit2WebExtension-4_0-2.36.3-150400.4.3.1 typelib-1_0-WebKit2WebExtension-4_1-2.36.3-150400.4.3.1 typelib-1_0-WebKit2WebExtension-5_0-2.36.3-150400.4.3.1 webkit-jsc-4-2.36.3-150400.4.3.1
webkit-jsc-4-debuginfo-2.36.3-150400.4.3.1
webkit-jsc-4.1-2.36.3-150400.4.3.1
webkit-jsc-4.1-debuginfo-2.36.3-150400.4.3.1
webkit-jsc-5.0-2.36.3-150400.4.3.1
webkit-jsc-5.0-debuginfo-2.36.3-150400.4.3.1
webkit2gtk-4_0-injected-bundles-2.36.3-150400.4.3.1
webkit2gtk-4_0-injected-bundles-debuginfo-2.36.3-150400.4.3.1 webkit2gtk-4_1-injected-bundles-2.36.3-150400.4.3.1
webkit2gtk-4_1-injected-bundles-debuginfo-2.36.3-150400.4.3.1 webkit2gtk-5_0-injected-bundles-2.36.3-150400.4.3.1
webkit2gtk-5_0-injected-bundles-debuginfo-2.36.3-150400.4.3.1 webkit2gtk3-debugsource-2.36.3-150400.4.3.1
webkit2gtk3-devel-2.36.3-150400.4.3.1
webkit2gtk3-minibrowser-2.36.3-150400.4.3.1
webkit2gtk3-minibrowser-debuginfo-2.36.3-150400.4.3.1 webkit2gtk3-soup2-debugsource-2.36.3-150400.4.3.1
webkit2gtk3-soup2-devel-2.36.3-150400.4.3.1
webkit2gtk3-soup2-minibrowser-2.36.3-150400.4.3.1
webkit2gtk3-soup2-minibrowser-debuginfo-2.36.3-150400.4.3.1 webkit2gtk4-debugsource-2.36.3-150400.4.3.1
webkit2gtk4-devel-2.36.3-150400.4.3.1
webkit2gtk4-minibrowser-2.36.3-150400.4.3.1
webkit2gtk4-minibrowser-debuginfo-2.36.3-150400.4.3.1
- openSUSE Leap 15.4 (x86_64):

libjavascriptcoregtk-4_0-18-32bit-2.36.3-150400.4.3.1 libjavascriptcoregtk-4_0-18-32bit-debuginfo-2.36.3-150400.4.3.1 libjavascriptcoregtk-4_1-0-32bit-2.36.3-150400.4.3.1
libjavascriptcoregtk-4_1-0-32bit-debuginfo-2.36.3-150400.4.3.1 libwebkit2gtk-4_0-37-32bit-2.36.3-150400.4.3.1
libwebkit2gtk-4_0-37-32bit-debuginfo-2.36.3-150400.4.3.1 libwebkit2gtk-4_1-0-32bit-2.36.3-150400.4.3.1
libwebkit2gtk-4_1-0-32bit-debuginfo-2.36.3-150400.4.3.1
- openSUSE Leap 15.4 (noarch):

WebKit2GTK-4.0-lang-2.36.3-150400.4.3.1
WebKit2GTK-4.1-lang-2.36.3-150400.4.3.1
WebKit2GTK-5.0-lang-2.36.3-150400.4.3.1

- SUSE Linux Enterprise Module for Development Tools 15-SP4 (aarch64 ppc64le s390x x86_64):

libjavascriptcoregtk-5_0-0-2.36.3-150400.4.3.1
libjavascriptcoregtk-5_0-0-debuginfo-2.36.3-150400.4.3.1 libwebkit2gtk-5_0-0-2.36.3-150400.4.3.1
libwebkit2gtk-5_0-0-debuginfo-2.36.3-150400.4.3.1
typelib-1_0-JavaScriptCore-5_0-2.36.3-150400.4.3.1
typelib-1_0-WebKit2-5_0-2.36.3-150400.4.3.1
webkit2gtk-5_0-injected-bundles-2.36.3-150400.4.3.1
webkit2gtk-5_0-injected-bundles-debuginfo-2.36.3-150400.4.3.1 webkit2gtk4-debugsource-2.36.3-150400.4.3.1

- SUSE Linux Enterprise Module for Desktop Applications 15-SP4 (aarch64 ppc64le s390x x86_64):

libjavascriptcoregtk-4_1-0-2.36.3-150400.4.3.1
libjavascriptcoregtk-4_1-0-debuginfo-2.36.3-150400.4.3.1 libwebkit2gtk-4_1-0-2.36.3-150400.4.3.1
libwebkit2gtk-4_1-0-debuginfo-2.36.3-150400.4.3.1
typelib-1_0-JavaScriptCore-4_1-2.36.3-150400.4.3.1
typelib-1_0-WebKit2-4_1-2.36.3-150400.4.3.1
typelib-1_0-WebKit2WebExtension-4_1-2.36.3-150400.4.3.1 webkit2gtk-4_1-injected-bundles-2.36.3-150400.4.3.1
webkit2gtk-4_1-injected-bundles-debuginfo-2.36.3-150400.4.3.1 webkit2gtk3-debugsource-2.36.3-150400.4.3.1
webkit2gtk3-devel-2.36.3-150400.4.3.1

- SUSE Linux Enterprise Module for Basesystem 15-SP4 (aarch64 ppc64le s390x x86_64):

libjavascriptcoregtk-4_0-18-2.36.3-150400.4.3.1
libjavascriptcoregtk-4_0-18-debuginfo-2.36.3-150400.4.3.1 libwebkit2gtk-4_0-37-2.36.3-150400.4.3.1
libwebkit2gtk-4_0-37-debuginfo-2.36.3-150400.4.3.1
typelib-1_0-JavaScriptCore-4_0-2.36.3-150400.4.3.1
typelib-1_0-WebKit2-4_0-2.36.3-150400.4.3.1
typelib-1_0-WebKit2WebExtension-4_0-2.36.3-150400.4.3.1 webkit2gtk-4_0-injected-bundles-2.36.3-150400.4.3.1
webkit2gtk-4_0-injected-bundles-debuginfo-2.36.3-150400.4.3.1 webkit2gtk3-soup2-debugsource-2.36.3-150400.4.3.1
webkit2gtk3-soup2-devel-2.36.3-150400.4.3.1

References:

  https://www.suse.com/security/cve/CVE-2022-26700.html
  https://www.suse.com/security/cve/CVE-2022-26709.html
  https://www.suse.com/security/cve/CVE-2022-26716.html
  https://www.suse.com/security/cve/CVE-2022-26717.html
  https://www.suse.com/security/cve/CVE-2022-26719.html
  https://www.suse.com/security/cve/CVE-2022-30293.html
  https://bugzilla.suse.com/1199287
  https://bugzilla.suse.com/1200106