SUSE 5055 Published by

A u-boot security update has been released for SUSE Linux Enterprise and openSUSE Leap 15.3.



SUSE-SU-2022:2053-1: important: Security update for u-boot


SUSE Security Update: Security update for u-boot
______________________________________________________________________________

Announcement ID: SUSE-SU-2022:2053-1
Rating: important
References: #1199623 #1200363 #1200364
Cross-References: CVE-2022-30552 CVE-2022-30767 CVE-2022-30790
CVSS scores:
CVE-2022-30552 (SUSE): 7.1 CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
CVE-2022-30767 (NVD) : 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE-2022-30767 (SUSE): 6.3 CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CVE-2022-30790 (SUSE): 9.6 CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Affected Products:
SUSE Linux Enterprise Desktop 15-SP3
SUSE Linux Enterprise High Performance Computing 15-SP3 SUSE Linux Enterprise Module for Basesystem 15-SP3 SUSE Linux Enterprise Server 15-SP3
SUSE Linux Enterprise Server for SAP Applications 15-SP3SUSE Manager Proxy 4.2
SUSE Manager Server 4.2
openSUSE Leap 15.3
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.
Description:

This update for u-boot fixes the following issues:

- CVE-2022-30552: A large buffer overflow could have lead to a denial of service in the IP Packet deframentation code. (bsc#1200363) - CVE-2022-30790: A Hole Descriptor Overwrite could have lead to an arbitrary out of bounds write primitive. (bsc#1200364) - CVE-2022-30767: Fixed an unbounded memcpy with a failed length check leading to a buffer overflow (bsc#1199623).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:
- openSUSE Leap 15.3:

zypper in -t patch openSUSE-SLE-15.3-2022-2053=1

- SUSE Linux Enterprise Module for Basesystem 15-SP3:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP3-2022-2053=1

Package List:

- openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

u-boot-tools-2021.01-150300.7.12.1
u-boot-tools-debuginfo-2021.01-150300.7.12.1

- openSUSE Leap 15.3 (aarch64):

u-boot-avnetultra96rev1-2021.01-150300.7.12.1
u-boot-avnetultra96rev1-doc-2021.01-150300.7.12.1
u-boot-bananapim64-2021.01-150300.7.12.1
u-boot-bananapim64-doc-2021.01-150300.7.12.1
u-boot-dragonboard410c-2021.01-150300.7.12.1
u-boot-dragonboard410c-doc-2021.01-150300.7.12.1
u-boot-dragonboard820c-2021.01-150300.7.12.1
u-boot-dragonboard820c-doc-2021.01-150300.7.12.1
u-boot-evb-rk3399-2021.01-150300.7.12.1
u-boot-evb-rk3399-doc-2021.01-150300.7.12.1
u-boot-firefly-rk3399-2021.01-150300.7.12.1
u-boot-firefly-rk3399-doc-2021.01-150300.7.12.1
u-boot-geekbox-2021.01-150300.7.12.1
u-boot-geekbox-doc-2021.01-150300.7.12.1
u-boot-hikey-2021.01-150300.7.12.1
u-boot-hikey-doc-2021.01-150300.7.12.1
u-boot-khadas-vim-2021.01-150300.7.12.1
u-boot-khadas-vim-doc-2021.01-150300.7.12.1
u-boot-khadas-vim2-2021.01-150300.7.12.1
u-boot-khadas-vim2-doc-2021.01-150300.7.12.1
u-boot-libretech-ac-2021.01-150300.7.12.1
u-boot-libretech-ac-doc-2021.01-150300.7.12.1
u-boot-libretech-cc-2021.01-150300.7.12.1
u-boot-libretech-cc-doc-2021.01-150300.7.12.1
u-boot-ls1012afrdmqspi-2021.01-150300.7.12.1
u-boot-ls1012afrdmqspi-doc-2021.01-150300.7.12.1
u-boot-mvebudb-88f3720-2021.01-150300.7.12.1
u-boot-mvebudb-88f3720-doc-2021.01-150300.7.12.1
u-boot-mvebudbarmada8k-2021.01-150300.7.12.1
u-boot-mvebudbarmada8k-doc-2021.01-150300.7.12.1
u-boot-mvebuespressobin-88f3720-2021.01-150300.7.12.1 u-boot-mvebuespressobin-88f3720-doc-2021.01-150300.7.12.1 u-boot-mvebumcbin-88f8040-2021.01-150300.7.12.1
u-boot-mvebumcbin-88f8040-doc-2021.01-150300.7.12.1
u-boot-nanopia64-2021.01-150300.7.12.1
u-boot-nanopia64-doc-2021.01-150300.7.12.1
u-boot-odroid-c2-2021.01-150300.7.12.1
u-boot-odroid-c2-doc-2021.01-150300.7.12.1
u-boot-odroid-c4-2021.01-150300.7.12.1
u-boot-odroid-c4-doc-2021.01-150300.7.12.1
u-boot-odroid-n2-2021.01-150300.7.12.1
u-boot-odroid-n2-doc-2021.01-150300.7.12.1
u-boot-orangepipc2-2021.01-150300.7.12.1
u-boot-orangepipc2-doc-2021.01-150300.7.12.1
u-boot-p2371-2180-2021.01-150300.7.12.1
u-boot-p2371-2180-doc-2021.01-150300.7.12.1
u-boot-p2771-0000-500-2021.01-150300.7.12.1
u-boot-p2771-0000-500-doc-2021.01-150300.7.12.1
u-boot-p3450-0000-2021.01-150300.7.12.1
u-boot-p3450-0000-doc-2021.01-150300.7.12.1
u-boot-pine64plus-2021.01-150300.7.12.1
u-boot-pine64plus-doc-2021.01-150300.7.12.1
u-boot-pinebook-2021.01-150300.7.12.1
u-boot-pinebook-doc-2021.01-150300.7.12.1
u-boot-pinebook-pro-rk3399-2021.01-150300.7.12.1
u-boot-pinebook-pro-rk3399-doc-2021.01-150300.7.12.1
u-boot-pineh64-2021.01-150300.7.12.1
u-boot-pineh64-doc-2021.01-150300.7.12.1
u-boot-pinephone-2021.01-150300.7.12.1
u-boot-pinephone-doc-2021.01-150300.7.12.1
u-boot-poplar-2021.01-150300.7.12.1
u-boot-poplar-doc-2021.01-150300.7.12.1
u-boot-rock-pi-4-rk3399-2021.01-150300.7.12.1
u-boot-rock-pi-4-rk3399-doc-2021.01-150300.7.12.1
u-boot-rock64-rk3328-2021.01-150300.7.12.1
u-boot-rock64-rk3328-doc-2021.01-150300.7.12.1
u-boot-rock960-rk3399-2021.01-150300.7.12.1
u-boot-rock960-rk3399-doc-2021.01-150300.7.12.1
u-boot-rockpro64-rk3399-2021.01-150300.7.12.1
u-boot-rockpro64-rk3399-doc-2021.01-150300.7.12.1
u-boot-rpi3-2021.01-150300.7.12.1
u-boot-rpi3-doc-2021.01-150300.7.12.1
u-boot-rpi4-2021.01-150300.7.12.1
u-boot-rpi4-doc-2021.01-150300.7.12.1
u-boot-rpiarm64-2021.01-150300.7.12.1
u-boot-rpiarm64-doc-2021.01-150300.7.12.1
u-boot-xilinxzynqmpvirt-2021.01-150300.7.12.1
u-boot-xilinxzynqmpvirt-doc-2021.01-150300.7.12.1
u-boot-xilinxzynqmpzcu102rev10-2021.01-150300.7.12.1
u-boot-xilinxzynqmpzcu102rev10-doc-2021.01-150300.7.12.1
- SUSE Linux Enterprise Module for Basesystem 15-SP3 (aarch64 ppc64le s390x x86_64):

u-boot-tools-2021.01-150300.7.12.1
u-boot-tools-debuginfo-2021.01-150300.7.12.1

- SUSE Linux Enterprise Module for Basesystem 15-SP3 (aarch64):
u-boot-rpiarm64-2021.01-150300.7.12.1
u-boot-rpiarm64-doc-2021.01-150300.7.12.1

References:

  https://www.suse.com/security/cve/CVE-2022-30552.html
  https://www.suse.com/security/cve/CVE-2022-30767.html
  https://www.suse.com/security/cve/CVE-2022-30790.html
  https://bugzilla.suse.com/1199623
  https://bugzilla.suse.com/1200363
  https://bugzilla.suse.com/1200364