Red Hat 8825 Published by

RHUI 4.3.0 security update has been released for Red Hat Enterprise Linux 8.



RHSA-2023:0742-01: Low: RHUI 4.3.0 release - Security Fixes, Bug Fixes, and Enhancements Update



=====================================================================
Red Hat Security Advisory

Synopsis: Low: RHUI 4.3.0 release - Security Fixes, Bug Fixes, and Enhancements Update
Advisory ID: RHSA-2023:0742-01
Product: Red Hat Update Infrastructure
Advisory URL:   https://access.redhat.com/errata/RHSA-2023:0742
Issue date: 2023-02-13
CVE Names: CVE-2021-44420 CVE-2022-41323
=====================================================================

1. Summary:

An updated version of Red Hat Update Infrastructure (RHUI) is now
available. RHUI 4.3 fixes a security bug, introduces multiple new features,
and upgrades underlying Pulp to a Long Term Support (LTS) version.

2. Relevant releases/architectures:

RHUI 4 for RHEL 8 - noarch, x86_64

3. Description:

Red Hat Update Infrastructure (RHUI) offers a highly scalable, highly
redundant framework that enables you to manage repositories and content. It
also enables cloud providers to deliver content and updates to Red Hat
Enterprise Linux (RHEL) instances.

Security Fix(es):
* Django: Potential bypass of an upstream access control based on URL paths
(CVE-2021-44420)

* Django: Potential denial-of-service vulnerability in internationalized
URLs (CVE-2022-41323)

This RHUI update fixes the following bugs:

* Previously, `rhui-manager` failed to create an Alternate Content Source
package. With this update, the problem is now fixed and you can
successfully create an Alternate Content Source package.

* With this update, several parts of redundant code have been removed from
RHUI. Most notably, the unused `entitlement` argument in the custom
repository creation has been removed. Additionally, the Atomic and OSTree
functions have been removed because these features have been deprecated in
RHUI 4.

* Previously, CDS and HAProxy management used a variable called `port`.
However, this name is a reserved playbook keyword in Ansible. Consequently,
Ansible printed warnings about the use of this variable. With this update,
the variable has been renamed to `remote_port` which prevents the warnings.

* Previously, when the RHUA installation playbook failed, `rhui-installer`
exited with a status of 0, which normally indicates success. With this
update, the problem has been fixed, and `rhui-installer` exits with a
status of 1, indicating that the RHUA installation playbook has failed.

* Previously, RHUI did not accept proxy server settings when adding
container images. Consequently, RHUI was unable to synchronize container
images if the proxy server configuration was required to access the
container registries. With this update, RHUI now accepts proxy settings
when they are configured with the container images. As a result,
proxy-enabled RHUI environments can now synchronize container images.

* With this update, the misaligned text on the repository workflow screen
in the rhui-manager text interface has been fixed.

This RHUI update introduces the following enhancements:

* This update introduces a newer version of Pulp, `3.21.0`. Among other
upstream bug fixes and enhancements, this version changes how Pulp manages
ambiguous CDN repodata that contains a duplicate package
name-version-release string. Instead of failing, Pulp logs a warning and
allows the affected repository to be synchronized.(BZ#2134277)

* A new `rhui-manager` command is now available, `rhui-manager
[--noninteractive] cds reinstall --all`. With this command, you can
reinstall all of your CDS nodes using a single command. Additionally, you
do not need to specify any of the CDS host names.

4. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

For detailed instructions on how to apply this update, see:
  https://access.redhat.com/documentation/en-us/red_hat_update_infrastructure/4/html/migrating_red_hat_update_infrastructure/assembly_upgrading-red-hat-update-infrastructure_migrating-red-hat-update-infrastructure

For other information, see the product documentation:
  https://access.redhat.com/documentation/en-us/red_hat_update_infrastructure/4

5. Bugs fixed (  https://bugzilla.redhat.com/):

2028178 - CVE-2021-44420 django: potential bypass of an upstream access control based on URL paths
2134277 - Using mirroring by default leads to errors with RH repos
2136130 - CVE-2022-41323 python-django: Potential denial-of-service vulnerability in internationalized URLs

6. JIRA issues fixed (  https://issues.jboss.org/):

RHUI-124 - Creating an alternate source configuration RPM is broken
RHUI-149 - Unused "entitlement" argument in custom repo creation
RHUI-169 - [WARNING]: Found variable using reserved name: port
RHUI-214 - Removal of atomic and OSTree client code
RHUI-296 - Update pulp to latest LTS version
RHUI-336 - rhui-installer exits with 0 even if the RHUA installation playbook fails
RHUI-341 - RFE: reinstall all CDS nodes in one simple step
RHUI-355 - Can't sync an ARM64 container
RHUI-94 - slightly incorrect formatting on the wf screen

7. Package List:

RHUI 4 for RHEL 8:

Source:
createrepo_c-0.20.1-1.0.1.el8ui.src.rpm
libcomps-0.1.18-4.0.1.el8ui.src.rpm
libsolv-0.7.22-4.0.1.el8ui.src.rpm
pulpcore-selinux-1.3.2-1.0.1.el8ui.src.rpm
python-aiodns-3.0.0-4.1.1.el8ui.src.rpm
python-aiofiles-22.1.0-1.0.1.el8ui.src.rpm
python-aiohttp-3.8.1-3.0.1.el8ui.src.rpm
python-aiohttp-xmlrpc-1.5.0-2.0.1.el8ui.src.rpm
python-aioredis-2.0.1-2.0.1.el8ui.src.rpm
python-aiosignal-1.2.0-2.0.1.el8ui.src.rpm
python-asgiref-3.5.2-1.0.1.el8ui.src.rpm
python-async-timeout-4.0.2-2.0.1.el8ui.src.rpm
python-asyncio-throttle-1.0.2-4.1.1.el8ui.src.rpm
python-attrs-21.4.0-2.0.1.el8ui.src.rpm
python-backoff-2.1.2-1.0.1.el8ui.src.rpm
python-brotli-1.0.9-2.0.1.el8ui.src.rpm
python-cchardet-2.1.7-4.0.1.el8ui.src.rpm
python-charset-normalizer-2.1.1-1.0.1.el8ui.src.rpm
python-click-8.1.3-1.0.1.el8ui.src.rpm
python-defusedxml-0.7.1-3.0.1.el8ui.src.rpm
python-deprecated-1.2.13-1.0.1.el8ui.src.rpm
python-diff-match-patch-20200713-3.0.1.el8ui.src.rpm
python-django-3.2.16-1.0.1.el8ui.src.rpm
python-django-currentuser-0.5.3-5.0.1.el8ui.src.rpm
python-django-filter-22.1-2.0.1.el8ui.src.rpm
python-django-guid-3.3.0-1.0.1.el8ui.src.rpm
python-django-import-export-2.8.0-1.0.1.el8ui.src.rpm
python-django-lifecycle-1.0.0-1.0.1.el8ui.src.rpm
python-django-readonly-field-1.1.1-3.0.1.el8ui.src.rpm
python-djangorestframework-3.13.1-2.0.1.el8ui.src.rpm
python-djangorestframework-queryfields-1.0.0-6.1.1.el8ui.src.rpm
python-drf-access-policy-1.1.2-1.0.1.el8ui.src.rpm
python-drf-nested-routers-0.93.4-3.0.1.el8ui.src.rpm
python-drf-spectacular-0.23.1-1.0.1.el8ui.src.rpm
python-dynaconf-3.1.9-1.0.1.el8ui.src.rpm
python-ecdsa-0.14.1-2.0.1.el8ui.src.rpm
python-et-xmlfile-1.1.0-2.0.3.el8ui.src.rpm
python-frozenlist-1.3.0-2.0.1.el8ui.src.rpm
python-future-0.18.2-5.0.1.el8ui.src.rpm
python-gnupg-0.5.0-1.0.1.el8ui.src.rpm
python-gunicorn-20.1.0-7.1.1.el8ui.src.rpm
python-idna-ssl-1.1.0-6.1.1.el8ui.src.rpm
python-inflection-0.5.1-4.1.1.el8ui.src.rpm
python-jinja2-3.1.2-1.0.1.el8ui.src.rpm
python-jsonschema-4.9.1-1.0.1.el8ui.src.rpm
python-markuppy-1.14-3.0.1.el8ui.src.rpm
python-markupsafe-2.0.1-3.0.2.el8ui.src.rpm
python-multidict-6.0.2-2.0.1.el8ui.src.rpm
python-naya-1.1.1-3.0.1.el8ui.src.rpm
python-odfpy-1.4.1-6.0.1.el8ui.src.rpm
python-openpyxl-3.0.9-2.0.1.el8ui.src.rpm
python-packaging-21.3-1.0.1.el8ui.src.rpm
python-productmd-1.33-4.1.1.el8ui.src.rpm
python-protobuf-4.21.6-1.0.1.el8ui.src.rpm
python-psycopg2-2.9.3-2.0.1.el8ui.src.rpm
python-pulp-container-2.14.3-1.0.1.el8ui.src.rpm
python-pulp-container-client-2.14.1-1.4.el8ui.src.rpm
python-pulp-rpm-3.18.5-1.0.1.el8ui.src.rpm
python-pulp-rpm-client-3.18.5-1.2.el8ui.src.rpm
python-pulpcore-3.21.0-1.0.1.el8ui.src.rpm
python-pulpcore-client-3.21.0-1.0.1.el8ui.src.rpm
python-pycairo-1.20.1-5.1.1.el8ui.src.rpm
python-pycares-4.1.2-2.0.1.el8ui.src.rpm
python-pycryptodomex-3.14.1-2.0.1.el8ui.src.rpm
python-pygobject-3.40.1-4.0.1.el8ui.src.rpm
python-pygtrie-2.5.0-1.0.1.el8ui.src.rpm
python-pyjwkest-1.4.2-6.0.1.el8ui.src.rpm
python-pyjwt-2.5.0-2.0.1.el8ui.src.rpm
python-pyparsing-2.4.7-4.0.1.el8ui.src.rpm
python-pyrsistent-0.18.1-2.0.1.el8ui.src.rpm
python-pytz-2022.2.1-1.0.1.el8ui.src.rpm
python-redis-4.3.4-1.0.1.el8ui.src.rpm
python-sqlparse-0.4.2-4.1.1.el8ui.src.rpm
python-tablib-3.2.0-3.0.1.el8ui.src.rpm
python-types-cryptography-3.3.23-1.0.1.el8ui.src.rpm
python-typing-extensions-3.10.0.2-3.1.1.el8ui.src.rpm
python-uritemplate-4.1.1-3.1.1.el8ui.src.rpm
python-url-normalize-1.4.3-4.0.1.el8ui.src.rpm
python-urlman-2.0.1-1.0.1.el8ui.src.rpm
python-whitenoise-6.0.0-1.0.1.el8ui.src.rpm
python-wrapt-1.14.1-1.0.1.el8ui.src.rpm
python-xlrd-2.0.1-5.0.1.el8ui.src.rpm
python-xlwt-1.3.0-3.0.1.el8ui.src.rpm
python-yarl-1.7.2-4.1.1.el8ui.src.rpm
rhui-installer-4.3.0.4-1.el8ui.src.rpm
rhui-tools-4.3.0.8-1.el8ui.src.rpm

noarch:
python3-gunicorn-20.1.0-7.1.1.el8ui.noarch.rpm
python3-pulp-container-client-2.14.1-1.4.el8ui.noarch.rpm
python3-pulp-rpm-client-3.18.5-1.2.el8ui.noarch.rpm
python3-pulpcore-client-3.21.0-1.0.1.el8ui.noarch.rpm
python39-aiodns-3.0.0-4.1.1.el8ui.noarch.rpm
python39-aiofiles-22.1.0-1.0.1.el8ui.noarch.rpm
python39-aiohttp-xmlrpc-1.5.0-2.0.1.el8ui.noarch.rpm
python39-aioredis-2.0.1-2.0.1.el8ui.noarch.rpm
python39-aiosignal-1.2.0-2.0.1.el8ui.noarch.rpm
python39-asgiref-3.5.2-1.0.1.el8ui.noarch.rpm
python39-async-timeout-4.0.2-2.0.1.el8ui.noarch.rpm
python39-asyncio-throttle-1.0.2-4.1.1.el8ui.noarch.rpm
python39-attrs-21.4.0-2.0.1.el8ui.noarch.rpm
python39-backoff-2.1.2-1.0.1.el8ui.noarch.rpm
python39-charset-normalizer-2.1.1-1.0.1.el8ui.noarch.rpm
python39-click-8.1.3-1.0.1.el8ui.noarch.rpm
python39-defusedxml-0.7.1-3.0.1.el8ui.noarch.rpm
python39-deprecated-1.2.13-1.0.1.el8ui.noarch.rpm
python39-diff-match-patch-20200713-3.0.1.el8ui.noarch.rpm
python39-django-3.2.16-1.0.1.el8ui.noarch.rpm
python39-django-currentuser-0.5.3-5.0.1.el8ui.noarch.rpm
python39-django-filter-22.1-2.0.1.el8ui.noarch.rpm
python39-django-guid-3.3.0-1.0.1.el8ui.noarch.rpm
python39-django-import-export-2.8.0-1.0.1.el8ui.noarch.rpm
python39-django-lifecycle-1.0.0-1.0.1.el8ui.noarch.rpm
python39-django-readonly-field-1.1.1-3.0.1.el8ui.noarch.rpm
python39-djangorestframework-3.13.1-2.0.1.el8ui.noarch.rpm
python39-djangorestframework-queryfields-1.0.0-6.1.1.el8ui.noarch.rpm
python39-drf-access-policy-1.1.2-1.0.1.el8ui.noarch.rpm
python39-drf-nested-routers-0.93.4-3.0.1.el8ui.noarch.rpm
python39-drf-spectacular-0.23.1-1.0.1.el8ui.noarch.rpm
python39-dynaconf-3.1.9-1.0.1.el8ui.noarch.rpm
python39-ecdsa-0.14.1-2.0.1.el8ui.noarch.rpm
python39-et-xmlfile-1.1.0-2.0.3.el8ui.noarch.rpm
python39-future-0.18.2-5.0.1.el8ui.noarch.rpm
python39-gnupg-0.5.0-1.0.1.el8ui.noarch.rpm
python39-gunicorn-20.1.0-7.1.1.el8ui.noarch.rpm
python39-idna-ssl-1.1.0-6.1.1.el8ui.noarch.rpm
python39-inflection-0.5.1-4.1.1.el8ui.noarch.rpm
python39-jinja2-3.1.2-1.0.1.el8ui.noarch.rpm
python39-jsonschema-4.9.1-1.0.1.el8ui.noarch.rpm
python39-markuppy-1.14-3.0.1.el8ui.noarch.rpm
python39-naya-1.1.1-3.0.1.el8ui.noarch.rpm
python39-odfpy-1.4.1-6.0.1.el8ui.noarch.rpm
python39-openpyxl-3.0.9-2.0.1.el8ui.noarch.rpm
python39-packaging-21.3-1.0.1.el8ui.noarch.rpm
python39-productmd-1.33-4.1.1.el8ui.noarch.rpm
python39-protobuf-4.21.6-1.0.1.el8ui.noarch.rpm
python39-pulp-container-2.14.3-1.0.1.el8ui.noarch.rpm
python39-pulp-rpm-3.18.5-1.0.1.el8ui.noarch.rpm
python39-pulpcore-3.21.0-1.0.1.el8ui.noarch.rpm
python39-pygtrie-2.5.0-1.0.1.el8ui.noarch.rpm
python39-pyjwkest-1.4.2-6.0.1.el8ui.noarch.rpm
python39-pyjwt-2.5.0-2.0.1.el8ui.noarch.rpm
python39-pyparsing-2.4.7-4.0.1.el8ui.noarch.rpm
python39-pytz-2022.2.1-1.0.1.el8ui.noarch.rpm
python39-redis-4.3.4-1.0.1.el8ui.noarch.rpm
python39-sqlparse-0.4.2-4.1.1.el8ui.noarch.rpm
python39-tablib-3.2.0-3.0.1.el8ui.noarch.rpm
python39-types-cryptography-3.3.23-1.0.1.el8ui.noarch.rpm
python39-typing-extensions-3.10.0.2-3.1.1.el8ui.noarch.rpm
python39-uritemplate-4.1.1-3.1.1.el8ui.noarch.rpm
python39-url-normalize-1.4.3-4.0.1.el8ui.noarch.rpm
python39-urlman-2.0.1-1.0.1.el8ui.noarch.rpm
python39-whitenoise-6.0.0-1.0.1.el8ui.noarch.rpm
python39-xlrd-2.0.1-5.0.1.el8ui.noarch.rpm
python39-xlwt-1.3.0-3.0.1.el8ui.noarch.rpm
rhui-installer-4.3.0.4-1.el8ui.noarch.rpm
rhui-tools-4.3.0.8-1.el8ui.noarch.rpm
rhui-tools-libs-4.3.0.8-1.el8ui.noarch.rpm

x86_64:
createrepo_c-debuginfo-0.20.1-1.0.1.el8ui.x86_64.rpm
createrepo_c-debugsource-0.20.1-1.0.1.el8ui.x86_64.rpm
createrepo_c-libs-0.20.1-1.0.1.el8ui.x86_64.rpm
createrepo_c-libs-debuginfo-0.20.1-1.0.1.el8ui.x86_64.rpm
libcomps-0.1.18-4.0.1.el8ui.x86_64.rpm
libcomps-debuginfo-0.1.18-4.0.1.el8ui.x86_64.rpm
libcomps-debugsource-0.1.18-4.0.1.el8ui.x86_64.rpm
libsolv-0.7.22-4.0.1.el8ui.x86_64.rpm
libsolv-debuginfo-0.7.22-4.0.1.el8ui.x86_64.rpm
libsolv-debugsource-0.7.22-4.0.1.el8ui.x86_64.rpm
libsolv-demo-debuginfo-0.7.22-4.0.1.el8ui.x86_64.rpm
libsolv-tools-debuginfo-0.7.22-4.0.1.el8ui.x86_64.rpm
pulpcore-selinux-1.3.2-1.0.1.el8ui.x86_64.rpm
python-aiohttp-debugsource-3.8.1-3.0.1.el8ui.x86_64.rpm
python-brotli-debugsource-1.0.9-2.0.1.el8ui.x86_64.rpm
python-cchardet-debugsource-2.1.7-4.0.1.el8ui.x86_64.rpm
python-frozenlist-debugsource-1.3.0-2.0.1.el8ui.x86_64.rpm
python-markupsafe-debuginfo-2.0.1-3.0.2.el8ui.x86_64.rpm
python-markupsafe-debugsource-2.0.1-3.0.2.el8ui.x86_64.rpm
python-multidict-debugsource-6.0.2-2.0.1.el8ui.x86_64.rpm
python-psycopg2-debugsource-2.9.3-2.0.1.el8ui.x86_64.rpm
python-pycairo-debugsource-1.20.1-5.1.1.el8ui.x86_64.rpm
python-pycares-debugsource-4.1.2-2.0.1.el8ui.x86_64.rpm
python-pycryptodomex-debugsource-3.14.1-2.0.1.el8ui.x86_64.rpm
python-pygobject-debugsource-3.40.1-4.0.1.el8ui.x86_64.rpm
python-pyrsistent-debugsource-0.18.1-2.0.1.el8ui.x86_64.rpm
python-wrapt-debugsource-1.14.1-1.0.1.el8ui.x86_64.rpm
python-yarl-debugsource-1.7.2-4.1.1.el8ui.x86_64.rpm
python3-createrepo_c-0.20.1-1.0.1.el8ui.x86_64.rpm
python3-createrepo_c-debuginfo-0.20.1-1.0.1.el8ui.x86_64.rpm
python3-libcomps-0.1.18-4.0.1.el8ui.x86_64.rpm
python3-libcomps-debuginfo-0.1.18-4.0.1.el8ui.x86_64.rpm
python3-markupsafe-debuginfo-2.0.1-3.0.2.el8ui.x86_64.rpm
python3-solv-0.7.22-4.0.1.el8ui.x86_64.rpm
python3-solv-debuginfo-0.7.22-4.0.1.el8ui.x86_64.rpm
python39-aiohttp-3.8.1-3.0.1.el8ui.x86_64.rpm
python39-aiohttp-debuginfo-3.8.1-3.0.1.el8ui.x86_64.rpm
python39-brotli-1.0.9-2.0.1.el8ui.x86_64.rpm
python39-brotli-debuginfo-1.0.9-2.0.1.el8ui.x86_64.rpm
python39-cchardet-2.1.7-4.0.1.el8ui.x86_64.rpm
python39-cchardet-debuginfo-2.1.7-4.0.1.el8ui.x86_64.rpm
python39-createrepo_c-0.20.1-1.0.1.el8ui.x86_64.rpm
python39-createrepo_c-debuginfo-0.20.1-1.0.1.el8ui.x86_64.rpm
python39-frozenlist-1.3.0-2.0.1.el8ui.x86_64.rpm
python39-frozenlist-debuginfo-1.3.0-2.0.1.el8ui.x86_64.rpm
python39-libcomps-0.1.18-4.0.1.el8ui.x86_64.rpm
python39-libcomps-debuginfo-0.1.18-4.0.1.el8ui.x86_64.rpm
python39-markupsafe-2.0.1-3.0.2.el8ui.x86_64.rpm
python39-markupsafe-debuginfo-2.0.1-3.0.2.el8ui.x86_64.rpm
python39-multidict-6.0.2-2.0.1.el8ui.x86_64.rpm
python39-multidict-debuginfo-6.0.2-2.0.1.el8ui.x86_64.rpm
python39-psycopg2-2.9.3-2.0.1.el8ui.x86_64.rpm
python39-psycopg2-debuginfo-2.9.3-2.0.1.el8ui.x86_64.rpm
python39-pycairo-1.20.1-5.1.1.el8ui.x86_64.rpm
python39-pycairo-debuginfo-1.20.1-5.1.1.el8ui.x86_64.rpm
python39-pycares-4.1.2-2.0.1.el8ui.x86_64.rpm
python39-pycares-debuginfo-4.1.2-2.0.1.el8ui.x86_64.rpm
python39-pycryptodomex-3.14.1-2.0.1.el8ui.x86_64.rpm
python39-pycryptodomex-debuginfo-3.14.1-2.0.1.el8ui.x86_64.rpm
python39-pygobject-3.40.1-4.0.1.el8ui.x86_64.rpm
python39-pygobject-debuginfo-3.40.1-4.0.1.el8ui.x86_64.rpm
python39-pyrsistent-0.18.1-2.0.1.el8ui.x86_64.rpm
python39-pyrsistent-debuginfo-0.18.1-2.0.1.el8ui.x86_64.rpm
python39-solv-0.7.22-4.0.1.el8ui.x86_64.rpm
python39-solv-debuginfo-0.7.22-4.0.1.el8ui.x86_64.rpm
python39-wrapt-1.14.1-1.0.1.el8ui.x86_64.rpm
python39-wrapt-debuginfo-1.14.1-1.0.1.el8ui.x86_64.rpm
python39-yarl-1.7.2-4.1.1.el8ui.x86_64.rpm
python39-yarl-debuginfo-1.7.2-4.1.1.el8ui.x86_64.rpm
ruby-solv-debuginfo-0.7.22-4.0.1.el8ui.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
  https://access.redhat.com/security/team/key/

8. References:

  https://access.redhat.com/security/cve/CVE-2021-44420
  https://access.redhat.com/security/cve/CVE-2022-41323
  https://access.redhat.com/security/updates/classification/#low

9. Contact:

The Red Hat security contact is . More contact
details at   https://access.redhat.com/security/team/contact/

Copyright 2023 Red Hat, Inc.