Ubuntu 6376 Published by

Updated python-cryptography packages are available for Ubuntu Linux 24.04 LTS to address an issue that could cause a crash:

[USN-6673-3] python-cryptography vulnerability




[USN-6673-3] python-cryptography vulnerability


==========================================================================
Ubuntu Security Notice USN-6673-3
May 27, 2024

python-cryptography vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 24.04 LTS

Summary:

python-cryptography could be made to crash if it received specially crafted
input.

Software Description:
- python-cryptography: Cryptography Python library

Details:

USN-6673-1 provided a security update for python-cryptography.
This update provides the corresponding update for Ubuntu 24.04 LTS.

Original advisory details:

 It was discovered that python-cryptography incorrectly handled memory
 operations when processing mismatched PKCS#12 keys. A remote attacker could
 possibly use this issue to cause python-cryptography to crash, leading to a
 denial of service. This issue only affected Ubuntu 23.10. (CVE-2024-26130)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 24.04 LTS
  python3-cryptography            41.0.7-4ubuntu0.1

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-6673-3
  https://ubuntu.com/security/notices/USN-6673-1
  CVE-2024-26130

Package Information:
https://launchpad.net/ubuntu/+source/python-cryptography/41.0.7-4ubuntu0.1