Slackware 1068 Published by

New postfix packages are available for Slackware 15.0 and -current to fix a security issue:
postfix (SSA:2023-356-01)




postfix (SSA:2023-356-01)


postfix (SSA:2023-356-01)

New postfix packages are available for Slackware 15.0 and -current to
fix a security issue.

Here are the details from the Slackware 15.0 ChangeLog:
+--------------------------+
patches/packages/postfix-3.6.13-i586-1_slack15.0.txz: Upgraded.
Security: this release adds support to defend against an email spoofing
attack (SMTP smuggling) on recipients at a Postfix server. Sites
concerned about SMTP smuggling attacks should enable this feature on
Internet-facing Postfix servers. For compatibility with non-standard
clients, Postfix by default excludes clients in mynetworks from this
countermeasure.
The recommended settings are:
# Optionally disconnect remote SMTP clients that send bare newlines,
# but allow local clients with non-standard SMTP implementations
# such as netcat, fax machines, or load balancer health checks.
#
smtpd_forbid_bare_newline = yes
smtpd_forbid_bare_newline_exclusions = $mynetworks
The smtpd_forbid_bare_newline feature is disabled by default.
For more information, see:
https://www.postfix.org/smtp-smuggling.html
(* Security fix *)
+--------------------------+

Where to find the new packages:
+-----------------------------+

Thanks to the friendly folks at the OSU Open Source Lab
( http://osuosl.org) for donating FTP and rsync hosting
to the Slackware project! :-)

Also see the "Get Slack" section on http://slackware.com for
additional mirror sites near you.

Updated package for Slackware 15.0:
ftp://ftp.slackware.com/pub/slackware/slackware-15.0/patches/packages/postfix-3.6.13-i586-1_slack15.0.txz

Updated package for Slackware x86_64 15.0:
ftp://ftp.slackware.com/pub/slackware/slackware64-15.0/patches/packages/postfix-3.6.13-x86_64-1_slack15.0.txz

Updated package for Slackware -current:
ftp://ftp.slackware.com/pub/slackware/slackware-current/slackware/n/postfix-3.8.4-i586-1.txz

Updated package for Slackware x86_64 -current:
ftp://ftp.slackware.com/pub/slackware/slackware64-current/slackware64/n/postfix-3.8.4-x86_64-1.txz

MD5 signatures:
+-------------+

Slackware 15.0 package:
1d5c7eec8f39a89e957abf39a1e79560 postfix-3.6.13-i586-1_slack15.0.txz

Slackware x86_64 15.0 package:
7286fabbc87a7dfdcc2b1ab4c6c2f4f5 postfix-3.6.13-x86_64-1_slack15.0.txz

Slackware -current package:
27f27ac76a52652599dc7b7d885fa4e1 n/postfix-3.8.4-i586-1.txz

Slackware x86_64 -current package:
c49061c599d2667dbea79227b8e6bb18 n/postfix-3.8.4-x86_64-1.txz

Installation instructions:
+------------------------+

Upgrade the package as root:
# upgradepkg postfix-3.6.13-i586-1_slack15.0.txz

Restart the postfix server:
# /etc/rc.d/rc.postfix restart

+-----+

Slackware Linux Security Team
http://slackware.com/gpg-key