Debian 9988 Published by

Updated pillow packages are available for Debian GNU/Linux 8 ELTS, 9 ELTS, and 10 LTS to address multiple vulnerabilities:

[DLA 3768-1] pillow security update
ELA-1059-1 pillow security update




[DLA 3768-1] pillow security update


-------------------------------------------------------------------------
Debian LTS Advisory DLA-3768-1 debian-lts@lists.debian.org
https://www.debian.org/lts/security/ Sean Whitton
March 22, 2024 https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package : pillow
Version : 5.4.1-2+deb10u5
CVE ID : CVE-2021-23437 CVE-2022-22817 CVE-2023-44271

Multiple vulnerabilities were discovered in the Python Imaging Library
(PIL), an image processing library for Python.

CVE-2021-23437

It was discovered that the getrgb function was vulnerable to a
regular expression denial-of-service attack.

CVE-2022-22817

A fix for this CVE was announced in DSA-5053-1. It was discovered
that this fix was incomplete. This update completes the fix.

CVE-2023-44271

It was discovered that an overlong text length argument passed to an
ImageDraw instance could cause uncontrollable memory allocation and
denial-of-service.

For Debian 10 buster, these problems have been fixed in version
5.4.1-2+deb10u5.

We recommend that you upgrade your pillow packages.

For the detailed security status of pillow please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/pillow

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS



ELA-1059-1 pillow security update

Package : pillow
Version : 2.6.1-2+deb8u9 (jessie), 4.0.0-4+deb9u5 (stretch)

Related CVEs :
CVE-2021-23437
CVE-2022-22817
CVE-2023-44271
CVE-2023-50447

Multiple vulnerabilities were discovered in the Python Imaging Library (PIL),
an image processing library for Python.

CVE-2021-23437
It was discovered that the getrgb function was vulnerable to a regular
expression denial-of-service attack.

CVE-2022-22817
A fix for this CVE was announced in advisories DLA-2893-1 and ELA-546-1. It
was discovered that this fix was incomplete. This update completes the fix.

CVE-2023-44271
It was discovered that an overlong text length argument passed to an ImageDraw
instance could cause uncontrollable memory allocation and denial-of-service.

CVE-2023-50447
It was discovered that PIL.ImageMath.eval could permit arbitrary code
execution via the environment parameter (see also CVE-2022-22817, which
concerned the expression parameter).

ELA-1059-1 pillow security update