Oracle Linux 6192 Published by

The following security updates have been released for Oracle Linux:

ELBA-2024-0129 Oracle Linux 8 pacemaker bug fix update
ELSA-2024-0256 Moderate: Oracle Linux 8 python3 security update
ELBA-2024-0111 Oracle Linux 8 selinux-policy bug fix update
ELSA-2024-0253 Moderate: Oracle Linux 8 sqlite security update
ELBA-2024-0120 Oracle Linux 8 389-ds:1.4 bug fix update
ELBA-2024-12073 Oracle Linux 8 perl-DBD-SQLite bug fix update



ELBA-2024-0129 Oracle Linux 8 pacemaker bug fix update


Oracle Linux Bug Fix Advisory ELBA-2024-0129

http://linux.oracle.com/errata/ELBA-2024-0129.html

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

x86_64:
pacemaker-cluster-libs-2.1.6-9.1.0.1.el8_9.i686.rpm
pacemaker-cluster-libs-2.1.6-9.1.0.1.el8_9.x86_64.rpm
pacemaker-libs-2.1.6-9.1.0.1.el8_9.i686.rpm
pacemaker-libs-2.1.6-9.1.0.1.el8_9.x86_64.rpm
pacemaker-schemas-2.1.6-9.1.0.1.el8_9.noarch.rpm

aarch64:
pacemaker-cluster-libs-2.1.6-9.1.0.1.el8_9.aarch64.rpm
pacemaker-libs-2.1.6-9.1.0.1.el8_9.aarch64.rpm
pacemaker-schemas-2.1.6-9.1.0.1.el8_9.noarch.rpm

SRPMS:
http://oss.oracle.com/ol8/SRPMS-updates//pacemaker-2.1.6-9.1.0.1.el8_9.src.rpm

Description of changes:

[2.1.6-9.1.0.1]
- Upstream reference in pacemaker crm_report binary [Orabug: 32825154]
- Replace bug url [Orabug: 34202300]

[2.1.6-9.1]
- Revert the rest of the attrd shutdown race condition fix
- Related: RHEL-14052

[2.1.6-9]
- Avoid an error if the elected attrd is on a node that is shutting down
- Resolves: RHEL-14052



ELSA-2024-0256 Moderate: Oracle Linux 8 python3 security update


Oracle Linux Security Advisory ELSA-2024-0256

http://linux.oracle.com/errata/ELSA-2024-0256.html

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

x86_64:
platform-python-3.6.8-56.0.1.el8_9.3.i686.rpm
platform-python-3.6.8-56.0.1.el8_9.3.x86_64.rpm
platform-python-debug-3.6.8-56.0.1.el8_9.3.i686.rpm
platform-python-debug-3.6.8-56.0.1.el8_9.3.x86_64.rpm
platform-python-devel-3.6.8-56.0.1.el8_9.3.i686.rpm
platform-python-devel-3.6.8-56.0.1.el8_9.3.x86_64.rpm
python3-idle-3.6.8-56.0.1.el8_9.3.i686.rpm
python3-idle-3.6.8-56.0.1.el8_9.3.x86_64.rpm
python3-libs-3.6.8-56.0.1.el8_9.3.i686.rpm
python3-libs-3.6.8-56.0.1.el8_9.3.x86_64.rpm
python3-test-3.6.8-56.0.1.el8_9.3.i686.rpm
python3-test-3.6.8-56.0.1.el8_9.3.x86_64.rpm
python3-tkinter-3.6.8-56.0.1.el8_9.3.i686.rpm
python3-tkinter-3.6.8-56.0.1.el8_9.3.x86_64.rpm

aarch64:
platform-python-3.6.8-56.0.1.el8_9.3.aarch64.rpm
platform-python-debug-3.6.8-56.0.1.el8_9.3.aarch64.rpm
platform-python-devel-3.6.8-56.0.1.el8_9.3.aarch64.rpm
python3-idle-3.6.8-56.0.1.el8_9.3.aarch64.rpm
python3-libs-3.6.8-56.0.1.el8_9.3.aarch64.rpm
python3-test-3.6.8-56.0.1.el8_9.3.aarch64.rpm
python3-tkinter-3.6.8-56.0.1.el8_9.3.aarch64.rpm

SRPMS:
http://oss.oracle.com/ol8/SRPMS-updates//python3-3.6.8-56.0.1.el8_9.3.src.rpm

Related CVEs:

CVE-2023-27043

Description of changes:

[3.6.8-56.0.1.3]
- Security fix for CVE-2023-27043
Resolves: rhbz#2196183



ELBA-2024-0111 Oracle Linux 8 selinux-policy bug fix update


Oracle Linux Bug Fix Advisory ELBA-2024-0111

http://linux.oracle.com/errata/ELBA-2024-0111.html

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

x86_64:
selinux-policy-3.14.3-128.0.2.el8_9.1.noarch.rpm
selinux-policy-devel-3.14.3-128.0.2.el8_9.1.noarch.rpm
selinux-policy-doc-3.14.3-128.0.2.el8_9.1.noarch.rpm
selinux-policy-minimum-3.14.3-128.0.2.el8_9.1.noarch.rpm
selinux-policy-mls-3.14.3-128.0.2.el8_9.1.noarch.rpm
selinux-policy-sandbox-3.14.3-128.0.2.el8_9.1.noarch.rpm
selinux-policy-targeted-3.14.3-128.0.2.el8_9.1.noarch.rpm

aarch64:
selinux-policy-3.14.3-128.0.2.el8_9.1.noarch.rpm
selinux-policy-devel-3.14.3-128.0.2.el8_9.1.noarch.rpm
selinux-policy-doc-3.14.3-128.0.2.el8_9.1.noarch.rpm
selinux-policy-minimum-3.14.3-128.0.2.el8_9.1.noarch.rpm
selinux-policy-mls-3.14.3-128.0.2.el8_9.1.noarch.rpm
selinux-policy-sandbox-3.14.3-128.0.2.el8_9.1.noarch.rpm
selinux-policy-targeted-3.14.3-128.0.2.el8_9.1.noarch.rpm

SRPMS:
http://oss.oracle.com/ol8/SRPMS-updates//selinux-policy-3.14.3-128.0.2.el8_9.1.src.rpm

Description of changes:

[3.14.3-128.0.2.1]
- Allow selinux transition from ifconfig_t to httpd_t and sshd_t
- AVCs with samba-dcerpcd and samba_export_all_rw
- Allow mailman_domain to manage mailman_log_t link files [Orabug: 36160497]



ELSA-2024-0253 Moderate: Oracle Linux 8 sqlite security update


Oracle Linux Security Advisory ELSA-2024-0253

http://linux.oracle.com/errata/ELSA-2024-0253.html

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

x86_64:
lemon-3.26.0-19.0.1.el8_9.x86_64.rpm
sqlite-3.26.0-19.0.1.el8_9.i686.rpm
sqlite-3.26.0-19.0.1.el8_9.x86_64.rpm
sqlite-devel-3.26.0-19.0.1.el8_9.i686.rpm
sqlite-devel-3.26.0-19.0.1.el8_9.x86_64.rpm
sqlite-doc-3.26.0-19.0.1.el8_9.noarch.rpm
sqlite-libs-3.26.0-19.0.1.el8_9.i686.rpm
sqlite-libs-3.26.0-19.0.1.el8_9.x86_64.rpm

aarch64:
lemon-3.26.0-19.0.1.el8_9.aarch64.rpm
sqlite-3.26.0-19.0.1.el8_9.aarch64.rpm
sqlite-devel-3.26.0-19.0.1.el8_9.aarch64.rpm
sqlite-doc-3.26.0-19.0.1.el8_9.noarch.rpm
sqlite-libs-3.26.0-19.0.1.el8_9.aarch64.rpm

SRPMS:
http://oss.oracle.com/ol8/SRPMS-updates//sqlite-3.26.0-19.0.1.el8_9.src.rpm

Related CVEs:

CVE-2023-7104

Description of changes:

[3.26.0-19.0.1]
- Fixed CVE-2023-7104



ELBA-2024-0120 Oracle Linux 8 389-ds:1.4 bug fix update


Oracle Linux Bug Fix Advisory ELBA-2024-0120

http://linux.oracle.com/errata/ELBA-2024-0120.html

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

x86_64:
389-ds-base-1.4.3.37-2.module+el8.9.0+90126+20794c01.x86_64.rpm
389-ds-base-devel-1.4.3.37-2.module+el8.9.0+90126+20794c01.x86_64.rpm
389-ds-base-legacy-tools-1.4.3.37-2.module+el8.9.0+90126+20794c01.x86_64.rpm
389-ds-base-libs-1.4.3.37-2.module+el8.9.0+90126+20794c01.x86_64.rpm
389-ds-base-snmp-1.4.3.37-2.module+el8.9.0+90126+20794c01.x86_64.rpm
python3-lib389-1.4.3.37-2.module+el8.9.0+90126+20794c01.noarch.rpm

aarch64:
389-ds-base-1.4.3.37-2.module+el8.9.0+90126+20794c01.aarch64.rpm
389-ds-base-devel-1.4.3.37-2.module+el8.9.0+90126+20794c01.aarch64.rpm
389-ds-base-legacy-tools-1.4.3.37-2.module+el8.9.0+90126+20794c01.aarch64.rpm
389-ds-base-libs-1.4.3.37-2.module+el8.9.0+90126+20794c01.aarch64.rpm
389-ds-base-snmp-1.4.3.37-2.module+el8.9.0+90126+20794c01.aarch64.rpm
python3-lib389-1.4.3.37-2.module+el8.9.0+90126+20794c01.noarch.rpm

SRPMS:
http://oss.oracle.com/ol8/SRPMS-updates//389-ds-base-1.4.3.37-2.module+el8.9.0+90126+20794c01.src.rpm

Description of changes:

[1.4.3.37-2]
- Resolves: JIRA:RHEL-12710 - bdb_start - Detected Disorderly Shutdown directory server is not starting.
- Resolves: JIRA:RHEL-16822 - ns-slapd crash in slapi_attr_basetype



ELBA-2024-12073 Oracle Linux 8 perl-DBD-SQLite bug fix update


Oracle Linux Bug Fix Advisory ELBA-2024-12073

http://linux.oracle.com/errata/ELBA-2024-12073.html

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

x86_64:
perl-DBD-SQLite-1.58-2.0.1.module+el8.8.0+90047+0a47edf3.x86_64.rpm
perl-DBD-SQLite-1.58-2.0.1.module+el8.8.0+90047+0a47edf3.x86_64.rpm

aarch64:
perl-DBD-SQLite-1.58-2.0.1.module+el8.8.0+90047+0a47edf3.aarch64.rpm
perl-DBD-SQLite-1.58-2.0.1.module+el8.8.0+90047+0a47edf3.aarch64.rpm

SRPMS:
http://oss.oracle.com/ol8/SRPMS-updates//perl-DBD-SQLite-1.58-2.0.1.module+el8.8.0+90047+0a47edf3.src.rpm

Description of changes:

[1.58-2.0.1]
- Rebuild