SUSE 5000 Published by

A keepass security update has been released for SUSE Linux Enterprise 15 SP5.



openSUSE-SU-2023:0163-1: important: Security update for keepass


openSUSE Security Update: Security update for keepass
_______________________________

Announcement ID: openSUSE-SU-2023:0163-1
Rating: important
References: #1211397
Cross-References: CVE-2023-32784
CVSS scores:
CVE-2023-32784 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products:
openSUSE Backports SLE-15-SP5
_______________________________

An update that fixes one vulnerability is now available.

Description:

This update for keepass fixes the following issues:

- Update to 2.54

* Security:

+ Improved process memory protection of secure edit controls
(CVE-2023-32784, boo#1211397).

* New Features:

+ Triggers, global URL overrides, password generator profiles and a
few more settings are now stored in the enforced configuration file.
+ Added dialog 'Enforce Options (All Users)' (menu 'Tools' â
'Advanced Tools' â 'Enforce Options'), which facilitates storing
certain options in the enforced configuration file.
+ In report dialogs, passwords (and other sensitive data) are now
hidden using asterisks by default (if hiding is activated in the
main window); the hiding can be toggled using the new '***' button
in the toolbar.
+ The 'Print' command in most report dialogs now requires the 'Print'
application policy flag, and the master key must be entered if the
'Print - No Key Repeat' application policy flag is deactivated.
+ The 'Export' command in most report dialogs now requires the
'Export' application policy flag, and the master key must be entered.
+ Single line edit dialogs now support hiding the value using
asterisks.
+ Commands that require elevation now have a shield icon like on
Windows.
+ TrlUtil: added 'Move Selected Unused Text to Dialog Control' command.

* Improvements:

* The content mode of the configuration elements
'/Configuration/Application/TriggerSystem',
'/Configuration/Integration/UrlSchemeOverrides' and
'/Configuration/PasswordGenerator/UserProfiles' is now 'Replace' by
default.
* The built-in override for the 'ssh' URI scheme is now deactivated by
default (it can be activated in the 'URL Overrides' dialog).
* When opening the password generator dialog without a derived
profile, the '(Automatically generated passwords for new entries)'
profile is now selected by default, if profiles are enabled
(otherwise the default profile is used).
* The clipboard workarounds are now disabled by default (they are not
needed anymore on most systems).
* Improved clipboard clearing.
* Improved starting of an elevated process.

* Bugfixes:

+ In report dialogs, the 'Print' and 'Export' commands now always use
the actual data (in previous versions, asterisks were
printed/exported when the application policy flag 'Unhide Passwords'
was turned off).

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Backports SLE-15-SP5:

zypper in -t patch openSUSE-2023-163=1

Package List:

- openSUSE Backports SLE-15-SP5 (noarch):

keepass-2.54-bp155.2.3.1

References:

https://www.suse.com/security/cve/CVE-2023-32784.html
https://bugzilla.suse.com/1211397