SUSE 5001 Published by

A xonotic security update has been released for SUSE Linux Enterprise SP4 and SP5.



openSUSE-SU-2023:0162-1: moderate: Security update for xonotic


openSUSE Security Update: Security update for xonotic
_______________________________

Announcement ID: openSUSE-SU-2023:0162-1
Rating: moderate
References: #1212632
Affected Products:
openSUSE Backports SLE-15-SP4
openSUSE Backports SLE-15-SP5
_______________________________

An update that contains security fixes can now be installed.

Description:

This update for xonotic fixes the following issues:

Update to version 0.8.6

SECURITY ALERT: A bug was discovered in versions older than 0.8.6 that is
believed to be exploitable by malicious server admins to crash clients or,
if they defeat mitigations, execute arbitrary code. (boo#1212632)

update to 0.8.5:

* https://xonotic.org/posts/2022/xonotic-0-8-5-release/

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Backports SLE-15-SP5:

zypper in -t patch openSUSE-2023-162=1

- openSUSE Backports SLE-15-SP4:

zypper in -t patch openSUSE-2023-162=1

Package List:

- openSUSE Backports SLE-15-SP5 (aarch64 ppc64le s390x x86_64):

xonotic-0.8.6-bp155.2.3.1
xonotic-debuginfo-0.8.6-bp155.2.3.1
xonotic-debugsource-0.8.6-bp155.2.3.1
xonotic-server-0.8.6-bp155.2.3.1
xonotic-server-debuginfo-0.8.6-bp155.2.3.1

- openSUSE Backports SLE-15-SP5 (noarch):

xonotic-data-0.8.6-bp155.2.3.1

- openSUSE Backports SLE-15-SP4 (aarch64 ppc64le s390x x86_64):

xonotic-0.8.6-bp154.3.3.1
xonotic-server-0.8.6-bp154.3.3.1

- openSUSE Backports SLE-15-SP4 (noarch):

xonotic-data-0.8.6-bp154.3.3.1

References:

https://bugzilla.suse.com/1212632