SUSE 5001 Published by

Ar libjxl security update has been released for SUSE Linux Enterprise 15 SP5.



openSUSE-SU-2023:0161-1: moderate: Security update for libjxl


openSUSE Security Update: Security update for libjxl
_______________________________

Announcement ID: openSUSE-SU-2023:0161-1
Rating: moderate
References: #1212492
Cross-References: CVE-2023-35790
CVSS scores:
CVE-2023-35790 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:
openSUSE Backports SLE-15-SP5
_______________________________

An update that fixes one vulnerability is now available.

Description:

This update for libjxl fixes the following issues:

Update to release 0.8.2

* CVE-2023-35790: Fix an integer underflow bug in patch decoding.
(bsc#1212492)

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Backports SLE-15-SP5:

zypper in -t patch openSUSE-2023-161=1

Package List:

- openSUSE Backports SLE-15-SP5 (aarch64 s390x x86_64):

libjxl-devel-0.8.2-bp155.2.3.1
libjxl-tools-0.8.2-bp155.2.3.1
libjxl0_8-0.8.2-bp155.2.3.1

- openSUSE Backports SLE-15-SP5 (aarch64_ilp32):

libjxl0_8-64bit-0.8.2-bp155.2.3.1

References:

https://www.suse.com/security/cve/CVE-2023-35790.html
https://bugzilla.suse.com/1212492