SUSE 5047 Published by

A python-Django security update has been released for SUSE Linux Enterprise 12.



openSUSE-SU-2023:0077-1: important: Security update for python-Django


openSUSE Security Update: Security update for python-Django
______________________________________________________________________________

Announcement ID: openSUSE-SU-2023:0077-1
Rating: important
References: #1077714 #1102680 #1208082 #937524 #952198
#988420
Cross-References: CVE-2015-3982 CVE-2015-5145 CVE-2015-5963
CVE-2017-12794 CVE-2017-7233 CVE-2017-7234
CVE-2018-14574 CVE-2018-6188 CVE-2018-7536
CVE-2018-7537 CVE-2023-24580
CVSS scores:
CVE-2017-12794 (NVD) : 6.1 CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVE-2017-7233 (NVD) : 6.1 CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVE-2017-7234 (NVD) : 6.1 CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVE-2018-14574 (NVD) : 6.1 CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVE-2018-14574 (SUSE): 4.2 CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:L
CVE-2018-6188 (NVD) : 7.5 CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVE-2018-7536 (NVD) : 5.3 CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
CVE-2018-7537 (NVD) : 5.3 CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
CVE-2018-7537 (SUSE): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
CVE-2023-24580 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE-2023-24580 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:
SUSE Linux Enterprise High Performance Computing 12
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12-SP3
SUSE Linux Enterprise Server 12-SP4
SUSE Linux Enterprise Server 12-SP5
SUSE Linux Enterprise Server for SAP Applications 12
SUSE Linux Enterprise Server for SAP Applications 12-SP3
SUSE Linux Enterprise Server for SAP Applications 12-SP4
SUSE Linux Enterprise Server for SAP Applications 12-SP5
SUSE Package Hub for SUSE Linux Enterprise 12
______________________________________________________________________________

An update that fixes 11 vulnerabilities is now available.

Description:

This update for python-Django fixes the following issues:

- CVE-2023-24580: Prevent DOS in file uploads. (boo#1208082)

update to 1.11.15

* CVE-2018-14574: Fixed Open redirect possibility in CommonMiddleware
(boo#1102680)
* Fixed WKBWriter.write() and write_hex() for empty polygons on GEOS
3.6.1+
* Fixed a regression in Django 1.10 that could result in large memory
usage when making edits using ModelAdmin.list_editable
* Fixed a regression in Django 1.11.12 where QuerySet.values() or
values_list() after combining an annotated and unannotated queryset
with union(), difference(), or intersection() crashed due to
mismatching columns
* Fixed crashes in django.contrib.admindocs when a view is a callable
object, such as django.contrib.syndication.views.Feed
* Fixed a regression in Django 1.11.8 where altering a field with a
unique constraint may drop and rebuild more foreign keys than necessary
* Fixed a regression in Django 1.11.8 where combining two annotated
values_list() querysets with union(), difference(), or intersection()
crashed due to mismatching columns
* Fixed a regression in Django 1.11 where an empty choice could be
initially selected for the SelectMultiple and CheckboxSelectMultiple
widgets

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Package Hub for SUSE Linux Enterprise 12:

zypper in -t patch openSUSE-2023-77=1


Package List:

- SUSE Package Hub for SUSE Linux Enterprise 12 (noarch):

python-Django-1.11.15-2.1

References:

  https://www.suse.com/security/cve/CVE-2015-3982.html
  https://www.suse.com/security/cve/CVE-2015-5145.html
  https://www.suse.com/security/cve/CVE-2015-5963.html
  https://www.suse.com/security/cve/CVE-2017-12794.html
  https://www.suse.com/security/cve/CVE-2017-7233.html
  https://www.suse.com/security/cve/CVE-2017-7234.html
  https://www.suse.com/security/cve/CVE-2018-14574.html
  https://www.suse.com/security/cve/CVE-2018-6188.html
  https://www.suse.com/security/cve/CVE-2018-7536.html
  https://www.suse.com/security/cve/CVE-2018-7537.html
  https://www.suse.com/security/cve/CVE-2023-24580.html
  https://bugzilla.suse.com/1077714
  https://bugzilla.suse.com/1102680
  https://bugzilla.suse.com/1208082
  https://bugzilla.suse.com/937524
  https://bugzilla.suse.com/952198
  https://bugzilla.suse.com/988420