SUSE 5058 Published by

A Botan security update has been released for SUSE Linux Enterprise 15 SP3.



openSUSE-SU-2022:10210-1: moderate: Security update for Botan


openSUSE Security Update: Security update for Botan
______________________________________________________________________________

Announcement ID: openSUSE-SU-2022:10210-1
Rating: moderate
References: #1205509
Cross-References: CVE-2022-43705
Affected Products:
openSUSE Backports SLE-15-SP3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for Botan fixes the following issues:

- CVE-2022-43705: Fixed validation of embedded certificates was when
checking OCSP responses (boo#1205509).

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Backports SLE-15-SP3:

zypper in -t patch openSUSE-2022-10210=1


Package List:

- openSUSE Backports SLE-15-SP3 (aarch64 i586 ppc64le s390x x86_64):

Botan-2.10.0-bp153.3.3.1
libbotan-2-10-2.10.0-bp153.3.3.1
libbotan-devel-2.10.0-bp153.3.3.1
python3-botan-2.10.0-bp153.3.3.1

- openSUSE Backports SLE-15-SP3 (aarch64_ilp32):

libbotan-2-10-64bit-2.10.0-bp153.3.3.1
libbotan-devel-64bit-2.10.0-bp153.3.3.1

- openSUSE Backports SLE-15-SP3 (noarch):

Botan-doc-2.10.0-bp153.3.3.1

- openSUSE Backports SLE-15-SP3 (x86_64):

libbotan-2-10-32bit-2.10.0-bp153.3.3.1
libbotan-devel-32bit-2.10.0-bp153.3.3.1

References:

  https://www.suse.com/security/cve/CVE-2022-43705.html
  https://bugzilla.suse.com/1205509