Oracle Linux 6138 Published by

New Ksplice updates for UEKR6 5.4.17 on Oracle Linux 7 and 8 are available.



New Ksplice updates for UEKR6 5.4.17 on OL7 and OL8 (CVE-2023-4911)


Synopsis: CVE-2023-4911 can now be patched using Ksplice
CVEs: CVE-2023-4911

Users with Oracle Linux Premier Support can now use Ksplice to patch
against CVE-2023-4911.

INSTALLING THE UPDATES

We recommend that all users of Ksplice Uptrack running UEKR6 5.4.17 on
OL7 and OL8 install these updates.

On systems that have "autoinstall = yes" in /etc/uptrack/uptrack.conf,
these updates will be installed automatically and you do not need to
take any action.

Alternatively, you can install these updates by running:

# /usr/sbin/uptrack-upgrade -y

DESCRIPTION

* CVE-2023-4911: Buffer overflow in the GNU C Library's dynamic loader while processing environment variables.

Incorrect processing of environment variables in the GNU C Library's
dynamic loader ld.so can result in buffer overflow. This flaw could
allow a local attacker to elevate their privileges when launching
binaries with SUID permission.

SUPPORT

Ksplice support is available at ksplice-support_ww@oracle.com.