Oracle Linux 6138 Published by

The following new .NET 7.0, PostgreSQL, Kernel, Leapp repository, and ocfs2 tools updates are available for Oracle Linux:

ELBA-2023-7208 Oracle Linux 8 .NET 7.0 bugfix update
ELSA-2023-7581 Important: Oracle Linux 8 postgresql:13 security update
ELSA-2023-7549 Important: Oracle Linux 8 kernel security and bug fix update
ELBA-2023-13018 Oracle Linux 8 leapp-repository bug fix update
ELBA-2023-13010 Oracle Linux 7 ocfs2-tools bug fix update (aarch64)
ELBA-2023-13010 Oracle Linux 7 ocfs2-tools bug fix update





ELBA-2023-7208 Oracle Linux 8 .NET 7.0 bugfix update

Oracle Linux Bug Fix Advisory ELBA-2023-7208

http://linux.oracle.com/errata/ELBA-2023-7208.html

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

x86_64:
aspnetcore-runtime-7.0-7.0.13-2.0.1.el8_9.x86_64.rpm
aspnetcore-targeting-pack-7.0-7.0.13-2.0.1.el8_9.x86_64.rpm
dotnet-apphost-pack-7.0-7.0.13-2.0.1.el8_9.x86_64.rpm
dotnet-hostfxr-7.0-7.0.13-2.0.1.el8_9.x86_64.rpm
dotnet-runtime-7.0-7.0.13-2.0.1.el8_9.x86_64.rpm
dotnet-sdk-7.0-7.0.113-2.0.1.el8_9.x86_64.rpm
dotnet-targeting-pack-7.0-7.0.13-2.0.1.el8_9.x86_64.rpm
dotnet-templates-7.0-7.0.113-2.0.1.el8_9.x86_64.rpm
dotnet-sdk-7.0-source-built-artifacts-7.0.113-2.0.1.el8_9.x86_64.rpm

aarch64:
aspnetcore-runtime-7.0-7.0.13-2.0.1.el8_9.aarch64.rpm
aspnetcore-targeting-pack-7.0-7.0.13-2.0.1.el8_9.aarch64.rpm
dotnet-apphost-pack-7.0-7.0.13-2.0.1.el8_9.aarch64.rpm
dotnet-hostfxr-7.0-7.0.13-2.0.1.el8_9.aarch64.rpm
dotnet-runtime-7.0-7.0.13-2.0.1.el8_9.aarch64.rpm
dotnet-sdk-7.0-7.0.113-2.0.1.el8_9.aarch64.rpm
dotnet-targeting-pack-7.0-7.0.13-2.0.1.el8_9.aarch64.rpm
dotnet-templates-7.0-7.0.113-2.0.1.el8_9.aarch64.rpm
dotnet-sdk-7.0-source-built-artifacts-7.0.113-2.0.1.el8_9.aarch64.rpm

SRPMS:
http://oss.oracle.com/ol8/SRPMS-updates//dotnet7.0-7.0.113-2.0.1.el8_9.src.rpm

Description of changes:

[7.0.113-2.0.1]
- Add support for Oracle Linux

[7.0.113-2]
- Update to .NET SDK 7.0.113 and Runtime 7.0.13
- Resolves: RHEL-14474

_______________________________________________


ELSA-2023-7581 Important: Oracle Linux 8 postgresql:13 security update

Oracle Linux Security Advisory ELSA-2023-7581

http://linux.oracle.com/errata/ELSA-2023-7581.html

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

x86_64:
pgaudit-1.5.0-1.module+el8.9.0+90098+1560b6c2.x86_64.rpm
pg_repack-1.4.6-3.module+el8.9.0+90098+1560b6c2.x86_64.rpm
postgres-decoderbufs-0.10.0-2.module+el8.9.0+90098+1560b6c2.x86_64.rpm
postgresql-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.x86_64.rpm
postgresql-contrib-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.x86_64.rpm
postgresql-docs-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.x86_64.rpm
postgresql-plperl-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.x86_64.rpm
postgresql-plpython3-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.x86_64.rpm
postgresql-pltcl-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.x86_64.rpm
postgresql-server-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.x86_64.rpm
postgresql-server-devel-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.x86_64.rpm
postgresql-static-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.x86_64.rpm
postgresql-test-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.x86_64.rpm
postgresql-test-rpm-macros-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.noarch.rpm
postgresql-upgrade-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.x86_64.rpm
postgresql-upgrade-devel-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.x86_64.rpm

aarch64:
pgaudit-1.5.0-1.module+el8.9.0+90098+1560b6c2.aarch64.rpm
pg_repack-1.4.6-3.module+el8.9.0+90098+1560b6c2.aarch64.rpm
postgres-decoderbufs-0.10.0-2.module+el8.9.0+90098+1560b6c2.aarch64.rpm
postgresql-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.aarch64.rpm
postgresql-contrib-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.aarch64.rpm
postgresql-docs-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.aarch64.rpm
postgresql-plperl-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.aarch64.rpm
postgresql-plpython3-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.aarch64.rpm
postgresql-pltcl-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.aarch64.rpm
postgresql-server-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.aarch64.rpm
postgresql-server-devel-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.aarch64.rpm
postgresql-static-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.aarch64.rpm
postgresql-test-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.aarch64.rpm
postgresql-test-rpm-macros-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.noarch.rpm
postgresql-upgrade-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.aarch64.rpm
postgresql-upgrade-devel-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.aarch64.rpm

SRPMS:
http://oss.oracle.com/ol8/SRPMS-updates//pgaudit-1.5.0-1.module+el8.9.0+90098+1560b6c2.src.rpm
http://oss.oracle.com/ol8/SRPMS-updates//pg_repack-1.4.6-3.module+el8.9.0+90098+1560b6c2.src.rpm
http://oss.oracle.com/ol8/SRPMS-updates//postgres-decoderbufs-0.10.0-2.module+el8.9.0+90098+1560b6c2.src.rpm
http://oss.oracle.com/ol8/SRPMS-updates//postgresql-13.13-1.0.1.module+el8.9.0+90098+1560b6c2.src.rpm

Related CVEs:

CVE-2023-5868
CVE-2023-5869
CVE-2023-5870
CVE-2023-39417

Description of changes:

pgaudit
pg_repack
postgres-decoderbufs
postgresql
[13.13-1.0.1]
- Fixed postgresql port binding issue during bootup [Orabug: 35103668]

[13.13-1]
- Update to 13.13
- Fixes: CVE-2023-5868 CVE-2023-5869 CVE-2023-5870 CVE-2023-39417
- Resolves: RHEL-16085 RHEL-16123

_______________________________________________


ELSA-2023-7549 Important: Oracle Linux 8 kernel security and bug fix update

Oracle Linux Security Advisory ELSA-2023-7549

http://linux.oracle.com/errata/ELSA-2023-7549.html

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

x86_64:
bpftool-4.18.0-513.9.1.el8_9.x86_64.rpm
kernel-4.18.0-513.9.1.el8_9.x86_64.rpm
kernel-abi-stablelists-4.18.0-513.9.1.el8_9.noarch.rpm
kernel-core-4.18.0-513.9.1.el8_9.x86_64.rpm
kernel-cross-headers-4.18.0-513.9.1.el8_9.x86_64.rpm
kernel-debug-4.18.0-513.9.1.el8_9.x86_64.rpm
kernel-debug-core-4.18.0-513.9.1.el8_9.x86_64.rpm
kernel-debug-devel-4.18.0-513.9.1.el8_9.x86_64.rpm
kernel-debug-modules-4.18.0-513.9.1.el8_9.x86_64.rpm
kernel-debug-modules-extra-4.18.0-513.9.1.el8_9.x86_64.rpm
kernel-devel-4.18.0-513.9.1.el8_9.x86_64.rpm
kernel-doc-4.18.0-513.9.1.el8_9.noarch.rpm
kernel-headers-4.18.0-513.9.1.el8_9.x86_64.rpm
kernel-modules-4.18.0-513.9.1.el8_9.x86_64.rpm
kernel-modules-extra-4.18.0-513.9.1.el8_9.x86_64.rpm
kernel-tools-4.18.0-513.9.1.el8_9.x86_64.rpm
kernel-tools-libs-4.18.0-513.9.1.el8_9.x86_64.rpm
perf-4.18.0-513.9.1.el8_9.x86_64.rpm
python3-perf-4.18.0-513.9.1.el8_9.x86_64.rpm
kernel-tools-libs-devel-4.18.0-513.9.1.el8_9.x86_64.rpm

aarch64:
bpftool-4.18.0-513.9.1.el8_9.aarch64.rpm
kernel-cross-headers-4.18.0-513.9.1.el8_9.aarch64.rpm
kernel-headers-4.18.0-513.9.1.el8_9.aarch64.rpm
kernel-tools-4.18.0-513.9.1.el8_9.aarch64.rpm
kernel-tools-libs-4.18.0-513.9.1.el8_9.aarch64.rpm
perf-4.18.0-513.9.1.el8_9.aarch64.rpm
python3-perf-4.18.0-513.9.1.el8_9.aarch64.rpm
kernel-tools-libs-devel-4.18.0-513.9.1.el8_9.aarch64.rpm

SRPMS:
http://oss.oracle.com/ol8/SRPMS-updates//kernel-4.18.0-513.9.1.el8_9.src.rpm

Related CVEs:

CVE-2022-45884
CVE-2022-45886
CVE-2022-45919
CVE-2023-1192
CVE-2023-2163
CVE-2023-3812
CVE-2023-5178

Description of changes:

[4.18.0-513.9.1.el8_9.OL8]
- media: dvb-core: Fix use-after-free due to race at dvb_register_device() (Mauro Carvalho Chehab) {CVE-2022-45884}
- cifs: Fix UAF in cifs_demultiplex_thread() (Zhang Xiaoxu) {CVE-2023-1192}
- nvmet-tcp: Fix a possible UAF in queue intialization setup (Sagi Grimberg) {CVE-2023-5178}
- net: tun: fix bugs for oversize packet when napi frags enabled (Ziyang Xuan) {CVE-2023-3812}
- bpf: Fix incorrect verifier pruning due to missing register precision taints (Daniel Borkmann) (Andrii Nakryiko) {CVE-2023-2163}
- media: dvb-core: Fix use-after-free due to race condition at dvb_ca_en50221 (Hyunwoo Kim) {CVE-2022-45919}
- media: dvbdev: fix error logic at dvb_register_device() (Mauro Carvalho Chehab)
- media: dvbdev: Fix memleak in dvb_register_device (Dinghao Liu)
- media: dvb-core: Fix use-after-free due on race condition at dvb_net (Hyunwoo Kim} {CVE-2022-45886}

[4.18.0-513.5.1.el8_9.OL8]
- Update Oracle Linux certificates (Kevin Lyons)
- Disable signing for aarch64 (Ilya Okomin)
- Oracle Linux RHCK Module Signing Key was added to the kernel trusted keys list (olkmod_signing_key.pem) [Orabug: 29539237]
- Update x509.genkey [Orabug: 24817676]
- Conflict with shim-ia32 and shim-x64 <= 15.3-1.0.3
- Remove upstream reference during boot (Kevin Lyons) [Orabug: 34750652]
- Drop not needed patch

_______________________________________________


ELBA-2023-13018 Oracle Linux 8 leapp-repository bug fix update

Oracle Linux Bug Fix Advisory ELBA-2023-13018

http://linux.oracle.com/errata/ELBA-2023-13018.html

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

x86_64:
leapp-upgrade-el8toel9-0.19.0-1.0.8.el8.noarch.rpm
leapp-upgrade-el8toel9-deps-0.19.0-1.0.8.el8.noarch.rpm

aarch64:
leapp-upgrade-el8toel9-0.19.0-1.0.8.el8.noarch.rpm
leapp-upgrade-el8toel9-deps-0.19.0-1.0.8.el8.noarch.rpm

SRPMS:
http://oss.oracle.com/ol8/SRPMS-updates//leapp-repository-0.19.0-1.0.8.el8.src.rpm

Description of changes:

[- 0.19.0-1.0.8]
- 1060-Remove-Apache-Packages.patch [Orabug: 35972908]
- 1061-Remove-Libasan6-Package.patch [Orabug: 35948072]

_______________________________________________


ELBA-2023-13010 Oracle Linux 7 ocfs2-tools bug fix update (aarch64)

Oracle Linux Bug Fix Advisory ELBA-2023-13010

http://linux.oracle.com/errata/ELBA-2023-13010.html

The following updated rpms for Oracle Linux 7 have been uploaded to the Unbreakable Linux Network:

aarch64:
ocfs2-tools-1.8.6-16.el7.aarch64.rpm
ocfs2-tools-devel-1.8.6-16.el7.aarch64.rpm

SRPMS:
http://oss.oracle.com/ol7/SRPMS-updates//ocfs2-tools-1.8.6-16.el7.src.rpm

Description of changes:

[1.8.6-16.el7]
- ocfs2-tools: fix wrong url (Junxiao Bi) [Orabug: 35998531]

_______________________________________________


ELBA-2023-13010 Oracle Linux 7 ocfs2-tools bug fix update

Oracle Linux Bug Fix Advisory ELBA-2023-13010

http://linux.oracle.com/errata/ELBA-2023-13010.html

The following updated rpms for Oracle Linux 7 have been uploaded to the Unbreakable Linux Network:

x86_64:
ocfs2-tools-1.8.6-16.el7.x86_64.rpm
ocfs2-tools-devel-1.8.6-16.el7.x86_64.rpm

SRPMS:
http://oss.oracle.com/ol7/SRPMS-updates//ocfs2-tools-1.8.6-16.el7.src.rpm

Description of changes:

[1.8.6-16.el7]
- ocfs2-tools: fix wrong url (Junxiao Bi) [Orabug: 35998531]

_______________________________________________