Fedora Linux 8485 Published by

Updated ncurses packages are available for Fedora Linux 38 to address two security issues:

Fedora 38 Update: ncurses-6.4-7.20230520.fc38




Fedora 38 Update: ncurses-6.4-7.20230520.fc38


--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2024-96090dafaf
2024-01-31 01:41:22.934193
--------------------------------------------------------------------------------

Name : ncurses
Product : Fedora 38
Version : 6.4
Release : 7.20230520.fc38
URL : https://invisible-island.net/ncurses/ncurses.html
Summary : Ncurses support utilities
Description :
The curses library routines are a terminal-independent method of
updating character screens with reasonable optimization. The ncurses
(new curses) library is a freely distributable replacement for the
discontinued 4.4 BSD classic curses library.

This package contains support utilities, including a terminfo compiler
tic, a decompiler infocmp, clear, tput, tset, and a termcap conversion
tool captoinfo.

--------------------------------------------------------------------------------
Update Information:

Update to newer ncurses version, which fixes CVE-2023-29491 and CVE-2023-50495.
--------------------------------------------------------------------------------
ChangeLog:

* Tue Aug 22 2023 Miroslav Lichvar [mlichvar@redhat.com] 6.4-7.20230520
- ignore TERMINFO and HOME only if setuid/setgid/capability
* Thu Jul 20 2023 Fedora Release Engineering [releng@fedoraproject.org] - 6.4-6.20230520
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Tue Jun 27 2023 Debarshi Ray [rishi@fedoraproject.org] 6.4-5.20230520
- move foot entries to -base (#2217982)
* Mon May 22 2023 Miroslav Lichvar [mlichvar@redhat.com] 6.4-4.20230520
- update to 6.4-20230520
- build with options disabling root file access and environment
--------------------------------------------------------------------------------
References:

[ 1 ] Bug #2191704 - CVE-2023-29491 ncurses: Local users can trigger security-relevant memory corruption via malformed data
https://bugzilla.redhat.com/show_bug.cgi?id=2191704
[ 2 ] Bug #2254244 - CVE-2023-50495 ncurses: segmentation fault via _nc_wrap_entry()
https://bugzilla.redhat.com/show_bug.cgi?id=2254244
--------------------------------------------------------------------------------

This update can be installed with the "dnf" update program. Use
su -c 'dnf upgrade --advisory FEDORA-2024-96090dafaf' at the command
line. For more information, refer to the dnf documentation available at
http://dnf.readthedocs.io/en/latest/command_ref.html#upgrade-command-label

All packages are signed with the Fedora Project GPG key. More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
--------------------------------------------------------------------------------
--