Debian 9890 Published by

A vulnerability in the MariaDB database server has been addressed by the availability of updated MariaDB 10.3 packages for Debian GNU/Linux 10 LTS. This vulnerability allowed a high-privileged attacker to compromise a server, which resulted in unauthorized hangs or crashes. The most significant danger was a complete DOS attack on the server.

[DLA 3722-1] mariadb-10.3 security update




[DLA 3722-1] mariadb-10.3 security update


- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3722-1 debian-lts@lists.debian.org
https://www.debian.org/lts/security/ Bastien ROUCARIÃS
January 27, 2024 https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package : mariadb-10.3
Version : 1:10.3.39-0+deb10u2
CVE ID : CVE-2023-22084
Debian Bug : 1055034

A vulnerability was fixed in MariaDB, a database suite.
This vulnerability allowed a high privileged attacker
with network access to compromise a MariaDB Server.
Successful attacks of this vulnerability can
result in unauthorized ability to cause a hang
or frequently repeatable crash.

The main risk was a complete DOS of the sever.

For Debian 10 buster, this problem has been fixed in version
1:10.3.39-0+deb10u2.

We recommend that you upgrade your mariadb-10.3 packages.

For the detailed security status of mariadb-10.3 please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/mariadb-10.3

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS