Debian 10026 Published by

Updated Linux kernel packages are now available for Debian GNU/Linux 10 LTS to address a number of vulnerabilities that could lead to privilege escalation, denial of service, or data leaks:

[DSA 5658-1] linux security update




[DSA 5658-1] linux security update


- -------------------------------------------------------------------------
Debian Security Advisory DSA-5658-1 security@debian.org
https://www.debian.org/security/ Salvatore Bonaccorso
April 13, 2024 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : linux
CVE ID : CVE-2023-2176 CVE-2023-6270 CVE-2023-7042 CVE-2023-28746
CVE-2023-47233 CVE-2023-52429 CVE-2023-52434 CVE-2023-52435
CVE-2023-52583 CVE-2023-52584 CVE-2023-52587 CVE-2023-52588
CVE-2023-52589 CVE-2023-52593 CVE-2023-52594 CVE-2023-52595
CVE-2023-52597 CVE-2023-52598 CVE-2023-52599 CVE-2023-52600
CVE-2023-52601 CVE-2023-52602 CVE-2023-52603 CVE-2023-52604
CVE-2023-52606 CVE-2023-52607 CVE-2023-52616 CVE-2023-52617
CVE-2023-52618 CVE-2023-52619 CVE-2023-52620 CVE-2023-52621
CVE-2023-52622 CVE-2023-52623 CVE-2023-52630 CVE-2023-52631
CVE-2023-52632 CVE-2023-52633 CVE-2023-52635 CVE-2023-52637
CVE-2023-52638 CVE-2023-52639 CVE-2023-52640 CVE-2023-52641
CVE-2024-0340 CVE-2024-0841 CVE-2024-1151 CVE-2024-2201
CVE-2024-22099 CVE-2024-23850 CVE-2024-23851 CVE-2024-24857
CVE-2024-24858 CVE-2024-26581 CVE-2024-26582 CVE-2024-26583
CVE-2024-26584 CVE-2024-26585 CVE-2024-26586 CVE-2024-26590
CVE-2024-26593 CVE-2024-26600 CVE-2024-26601 CVE-2024-26602
CVE-2024-26603 CVE-2024-26606 CVE-2024-26621 CVE-2024-26622
CVE-2024-26625 CVE-2024-26626 CVE-2024-26627 CVE-2024-26629
CVE-2024-26639 CVE-2024-26640 CVE-2024-26641 CVE-2024-26642
CVE-2024-26643 CVE-2024-26651 CVE-2024-26654 CVE-2024-26659
CVE-2024-26660 CVE-2024-26663 CVE-2024-26664 CVE-2024-26665
CVE-2024-26667 CVE-2024-26671 CVE-2024-26673 CVE-2024-26675
CVE-2024-26676 CVE-2024-26679 CVE-2024-26680 CVE-2024-26681
CVE-2024-26684 CVE-2024-26685 CVE-2024-26686 CVE-2024-26687
CVE-2024-26688 CVE-2024-26689 CVE-2024-26695 CVE-2024-26696
CVE-2024-26697 CVE-2024-26698 CVE-2024-26700 CVE-2024-26702
CVE-2024-26704 CVE-2024-26706 CVE-2024-26707 CVE-2024-26710
CVE-2024-26712 CVE-2024-26714 CVE-2024-26715 CVE-2024-26717
CVE-2024-26718 CVE-2024-26720 CVE-2024-26722 CVE-2024-26723
CVE-2024-26726 CVE-2024-26727 CVE-2024-26731 CVE-2024-26733
CVE-2024-26735 CVE-2024-26736 CVE-2024-26737 CVE-2024-26741
CVE-2024-26742 CVE-2024-26743 CVE-2024-26744 CVE-2024-26745
CVE-2024-26747 CVE-2024-26748 CVE-2024-26749 CVE-2024-26750
CVE-2024-26751 CVE-2024-26752 CVE-2024-26753 CVE-2024-26754
CVE-2024-26759 CVE-2024-26760 CVE-2024-26761 CVE-2024-26763
CVE-2024-26764 CVE-2024-26765 CVE-2024-26766 CVE-2024-26769
CVE-2024-26771 CVE-2024-26772 CVE-2024-26773 CVE-2024-26774
CVE-2024-26775 CVE-2024-26776 CVE-2024-26777 CVE-2024-26778
CVE-2024-26779 CVE-2024-26780 CVE-2024-26781 CVE-2024-26782
CVE-2024-26787 CVE-2024-26788 CVE-2024-26789 CVE-2024-26790
CVE-2024-26791 CVE-2024-26792 CVE-2024-26793 CVE-2024-26795
CVE-2024-26798 CVE-2024-26800 CVE-2024-26801 CVE-2024-26802
CVE-2024-26803 CVE-2024-26804 CVE-2024-26805 CVE-2024-26809
CVE-2024-26810 CVE-2024-26811 CVE-2024-26812 CVE-2024-26813
CVE-2024-26814 CVE-2024-26815 CVE-2024-26816 CVE-2024-27437

Several vulnerabilities have been discovered in the Linux kernel that
may lead to a privilege escalation, denial of service or information
leaks.

For the stable distribution (bookworm), these problems have been fixed in
version 6.1.85-1.

We recommend that you upgrade your linux packages.

For the detailed security status of linux please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/linux

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/